Bug 84512

Summary: Repurpose ActiveDOMObject::WillShowDialog to WillDeferLoading
Product: WebKit Reporter: Brady Eidson <beidson>
Component: Page LoadingAssignee: Brady Eidson <beidson>
Severity: Normal CC: ap, eric.carlson, feature-media-reviews, jchaffraix, webkit.review.bot, yong.li.webkit
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: All   
OS: All   
Description Flags
Patch v1 - Do the rename and get rid of the unnecessary argument eric.carlson: review+

Description Brady Eidson 2012-04-20 16:46:42 PDT
Repurpose ActiveDOMObject::WillShowDialog to WillDeferLoading

All of the ActiveDOMObject ReasonForSuspensions are great, but only a *single* subclass does anything special for a particular Reason.  And it's not WillShowDialog.

WillShowDialog is used whenever we defer page loading and has no special meaning beyond that.

We should rename it, then use it by default in all page load deferral cases without having to pass the argument around.

Noticed while exploring https://bugs.webkit.org/show_bug.cgi?id=84488
Comment 1 Brady Eidson 2012-04-20 16:51:48 PDT
Created attachment 138199 [details]
Patch v1 - Do the rename and get rid of the unnecessary argument
Comment 2 Brady Eidson 2012-04-20 17:07:33 PDT