Bug 83830

Summary: Integrate IETC CSS : grid layout tests
Product: WebKit Reporter: Dave Tharp <dtharp@codeaurora.org>
Component: CSSAssignee: Dave Tharp <dtharp@codeaurora.org>
Status: RESOLVED FIXED    
Severity: Normal CC: abarth@webkit.org, tomz@codeaurora.org, webkit.review.bot@gmail.com
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
URL: http://samples.msdn.microsoft.com/ietestcenter/#css3grid
Bug Depends on:    
Bug Blocks: 81526    
Attachments:
Description Flags
Patch
none
Patch abarth: review+

Description From 2012-04-12 16:02:35 PST
Integrate the eleven css ietestcenter grid layout tests.  All eleven Fail, and bugs will be written against them.
------- Comment #1 From 2012-04-12 16:22:32 PST -------
Created an attachment (id=136992) [details]
Patch
------- Comment #2 From 2012-04-12 16:28:06 PST -------
Attachment 136992 [details] did not pass style-queue:

Failed to run "['Tools/Scripts/check-webkit-style', '--diff-files', u'LayoutTests/ChangeLog', u'LayoutTests/iete..." exit_code: 1
LayoutTests/platform/gtk/test_expectations.txt:1146:  More specific entry on line 1136 overrides line 1146 sputnik/Unicode/Unicode_510/S7.6_A5.3_T2.html  [test/expectations] [5]
LayoutTests/platform/gtk/test_expectations.txt:1147:  More specific entry on line 1135 overrides line 1147 sputnik/Unicode/Unicode_510/S7.6_A3.2.html  [test/expectations] [5]
Total errors found: 2 in 17 files


If any of these errors are false positives, please file a bug against check-webkit-style.
------- Comment #3 From 2012-04-12 16:33:44 PST -------
(In reply to comment #2)

Note these failures were already in the file.  I didn't fix them because I didn't want to interfere with potential ongoing gardening I am not involved in.

> Attachment 136992 [details] [details] did not pass style-queue:
> 
> Failed to run "['Tools/Scripts/check-webkit-style', '--diff-files', u'LayoutTests/ChangeLog', u'LayoutTests/iete..." exit_code: 1
> LayoutTests/platform/gtk/test_expectations.txt:1146:  More specific entry on line 1136 overrides line 1146 sputnik/Unicode/Unicode_510/S7.6_A5.3_T2.html  [test/expectations] [5]
> LayoutTests/platform/gtk/test_expectations.txt:1147:  More specific entry on line 1135 overrides line 1147 sputnik/Unicode/Unicode_510/S7.6_A3.2.html  [test/expectations] [5]
> Total errors found: 2 in 17 files
> 
> 
> If any of these errors are false positives, please file a bug against check-webkit-style.
------- Comment #4 From 2012-04-13 09:24:36 PST -------
Created an attachment (id=137093) [details]
Patch
------- Comment #5 From 2012-04-13 09:26:29 PST -------
(In reply to comment #4)
> Created an attachment (id=137093) [details] [details]
> Patch

OK, so the style error caused by the (unrelated to my tests) duplicate FAIL entries for the sputnik unicode tests was bugging me. So I fixed it along with the rest of my patch.
------- Comment #6 From 2012-04-13 11:08:13 PST -------
(In reply to comment #5)
> (In reply to comment #4)
> > Created an attachment (id=137093) [details] [details] [details]
> > Patch
> 
> OK, so the style error caused by the (unrelated to my tests) duplicate FAIL entries for the sputnik unicode tests was bugging me. So I fixed it along with the rest of my patch.

Just saw that zandobersek fixed the duplicates.  I'll remove my fix when I land this.
------- Comment #7 From 2012-04-13 11:14:47 PST -------
(From update of attachment 137093 [details])
rs=me
------- Comment #8 From 2012-04-13 12:39:42 PST -------
Committed r114162: <http://trac.webkit.org/changeset/114162>