Bug 83572

Summary: Height overflow when nesting multiple new Flexbox'es.
Product: WebKit Reporter: simurai <simulus>
Component: CSSAssignee: Tony Chang <tony>
Status: RESOLVED FIXED    
Severity: Critical CC: cmarcelo, ojan, paulirish, tony, vcarbune, webkit.review.bot
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Mac (Intel)   
OS: OS X 10.6   
URL: http://jsfiddle.net/simurai/BQW3Y/
Attachments:
Description Flags
Patch
none
Patch for landing none

simurai
Reported 2012-04-10 05:59:48 PDT
It appears that when nesting multiple "new" Flexbox'es, the total height of its flexible children are overflowing. See: http://jsfiddle.net/simurai/BQW3Y/ Note: In the old Flexbox ( display: -webkit-box; ) it works fine.
Attachments
Patch (5.01 KB, patch)
2012-05-03 14:35 PDT, Tony Chang
no flags
Patch for landing (6.46 KB, patch)
2012-05-03 14:56 PDT, Tony Chang
no flags
Tony Chang
Comment 1 2012-05-03 13:02:02 PDT
*** Bug 85490 has been marked as a duplicate of this bug. ***
Tony Chang
Comment 2 2012-05-03 14:35:53 PDT
Ojan Vafai
Comment 3 2012-05-03 14:44:45 PDT
Comment on attachment 140094 [details] Patch View in context: https://bugs.webkit.org/attachment.cgi?id=140094&action=review > Source/WebCore/rendering/RenderFlexibleBox.cpp:606 > + return overrideContentLogicalHeight - preferredMainAxisExtent; Now that all return cases subtract preferredMainAxisExtent, I wonder if we should rename this method computeMainAxisExtent and subtract preferredMainAxisExtent in the one calling location. Up to you.
Tony Chang
Comment 4 2012-05-03 14:56:16 PDT
Created attachment 140101 [details] Patch for landing
Tony Chang
Comment 5 2012-05-03 14:57:24 PDT
(In reply to comment #3) > (From update of attachment 140094 [details]) > View in context: https://bugs.webkit.org/attachment.cgi?id=140094&action=review > > > Source/WebCore/rendering/RenderFlexibleBox.cpp:606 > > + return overrideContentLogicalHeight - preferredMainAxisExtent; > > Now that all return cases subtract preferredMainAxisExtent, I wonder if we should rename this method computeMainAxisExtent and subtract preferredMainAxisExtent in the one calling location. I did a variation that subtracts preferredMainAxisExtent at the end of the method. It's convenient that the concept of available free space is a function.
WebKit Review Bot
Comment 6 2012-05-03 16:21:01 PDT
Comment on attachment 140101 [details] Patch for landing Clearing flags on attachment: 140101 Committed r116038: <http://trac.webkit.org/changeset/116038>
WebKit Review Bot
Comment 7 2012-05-03 16:21:10 PDT
All reviewed patches have been landed. Closing bug.
Note You need to log in before you can comment on or make changes to this bug.