Bug 83124

Summary: worker-reload.html flakily prints console messages
Product: WebKit Reporter: Yuta Kitamura <yutak>
Component: Tools / TestsAssignee: Yuta Kitamura <yutak>
Status: RESOLVED DUPLICATE    
Severity: Normal CC: pnormand
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   

Description Yuta Kitamura 2012-04-04 01:33:36 PDT
http/tests/websocket/tests/hybi/workers/worker-reload.html

This test prints the following console messages random number of times on Mac bots:

--- /Volumes/Data/slave/lion-intel-release-tests/build/layout-test-results/http/tests/websocket/tests/hybi/workers/worker-reload-expected.txt
+++ /Volumes/Data/slave/lion-intel-release-tests/build/layout-test-results/http/tests/websocket/tests/hybi/workers/worker-reload-actual.txt
@@ -1,3 +1,21 @@
+CONSOLE MESSAGE: WebSocket network error: The operation couldn’t be completed. Connection refused
+CONSOLE MESSAGE: WebSocket network error: The operation couldn’t be completed. Connection refused
+CONSOLE MESSAGE: WebSocket network error: The operation couldn’t be completed. Connection refused
+CONSOLE MESSAGE: WebSocket network error: The operation couldn’t be completed. Connection refused
+CONSOLE MESSAGE: WebSocket network error: The operation couldn’t be completed. Connection refused
+CONSOLE MESSAGE: WebSocket network error: The operation couldn’t be completed. Connection refused
+CONSOLE MESSAGE: WebSocket network error: The operation couldn’t be completed. Connection refused
+CONSOLE MESSAGE: WebSocket network error: The operation couldn’t be completed. Connection refused
+CONSOLE MESSAGE: WebSocket network error: The operation couldn’t be completed. Connection refused
+CONSOLE MESSAGE: WebSocket network error: The operation couldn’t be completed. Connection refused
+CONSOLE MESSAGE: WebSocket network error: The operation couldn’t be completed. Connection refused
+CONSOLE MESSAGE: WebSocket network error: The operation couldn’t be completed. Connection refused
+CONSOLE MESSAGE: WebSocket network error: The operation couldn’t be completed. Connection refused
+CONSOLE MESSAGE: WebSocket network error: The operation couldn’t be completed. Connection refused
+CONSOLE MESSAGE: WebSocket network error: The operation couldn’t be completed. Connection refused
+CONSOLE MESSAGE: WebSocket network error: The operation couldn’t be completed. Connection refused
+CONSOLE MESSAGE: WebSocket network error: The operation couldn’t be completed. Connection refused
+CONSOLE MESSAGE: WebSocket network error: The operation couldn’t be completed. Connection refused
 Reload after WebSocket creation should not cause a crash.
 
 On success, you will see a series of "PASS" messages, followed by "TEST COMPLETE".


On GTK Release bots, the test prints the similar message exactly 100 times (as the test reloads the same page 100 times).

These messages can be safely ignored (this test only checks for crashes), but we need to figure out a way to prevent these messages.
Comment 1 Yuta Kitamura 2012-04-04 18:06:22 PDT
I will fix this issue in bug 83173.

*** This bug has been marked as a duplicate of bug 83173 ***
Comment 2 Yuta Kitamura 2012-04-12 03:05:59 PDT
This was fixed.

http://test-results.appspot.com/dashboards/flakiness_dashboard.html#group=%40ToT%20-%20webkit.org&tests=worker-reload.html

I'm going to remove the expectations.