Bug 81975

Summary: DFG NodeFlags has some duplicate code and naming issues
Product: WebKit Reporter: Filip Pizlo <fpizlo>
Component: JavaScriptCoreAssignee: Nobody <webkit-unassigned>
Severity: Normal    
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: All   
OS: All   
Description Flags
the patch barraclough: review+

Description Filip Pizlo 2012-03-22 15:05:42 PDT
The notion that some flags are "ArithNodeFlags" is mostly antiquated.

The renaming from NodeUse to Edge messed up some node flags names (NodeUsedAsNum become EdgedAsNum ... ooops).

It appears that we have a method called setArithNodeFlag() which is never called.

It appears that we have both mergeArithNodeFlags and mergeFlags.  The former has some assertions, which may be useful - but it's sad that we have two methods that really do the same thing.
Comment 1 Filip Pizlo 2012-03-22 15:35:22 PDT
Created attachment 133368 [details]
the patch
Comment 2 Filip Pizlo 2012-03-22 16:25:46 PDT
Landed in http://trac.webkit.org/changeset/111781