Bug 81838

Summary: WTF::MetaAllocator has a weak vtable (discovered when building wtf as a static library)
Product: WebKit Reporter: Eric Seidel <eric@webkit.org>
Component: New BugsAssignee: Eric Seidel <eric@webkit.org>
Status: RESOLVED FIXED    
Severity: Normal CC: abarth@webkit.org, barraclough@apple.com, fpizlo@apple.com, ggaren@apple.com, mitz@webkit.org, mrowe@apple.com, webkit.review.bot@gmail.com
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Bug Depends on:    
Bug Blocks: 75673    
Attachments:
Description Flags
Patch
none
Patch for landing webkit.review.bot: commit‑queue-

Description From 2012-03-21 15:26:54 PST
WTF::MetaAllocator has a weak vtable (discovered when building wtf as a static library)
------- Comment #1 From 2012-03-21 15:30:43 PST -------
Created an attachment (id=133127) [details]
Patch
------- Comment #2 From 2012-03-21 15:32:22 PST -------
(From update of attachment 133127 [details])
r=me
------- Comment #3 From 2012-03-21 15:32:56 PST -------
(This patch won't actually apply to trunk, since it is on top of a local commit with the WTF files already moved to their new location.)
------- Comment #4 From 2012-03-21 15:36:01 PST -------
(From update of attachment 133127 [details])
Rejecting attachment 133127 [details] from commit-queue.

Failed to run "['/mnt/git/webkit-commit-queue/Tools/Scripts/webkit-patch', '--status-host=queues.webkit.org', '-..." exit_code: 2

Last 500 characters of output:
 file Source/WTF/ChangeLog
patching file Source/WTF/wtf/MetaAllocator.cpp
Hunk #1 FAILED at 33.
1 out of 1 hunk FAILED -- saving rejects to file Source/WTF/wtf/MetaAllocator.cpp.rej
patching file Source/WTF/wtf/MetaAllocator.h
Hunk #1 FAILED at 196.
1 out of 1 hunk FAILED -- saving rejects to file Source/WTF/wtf/MetaAllocator.h.rej

Failed to run "[u'/mnt/git/webkit-commit-queue/Tools/Scripts/svn-apply', u'--force', u'--reviewer', u'Geoffrey G..." exit_code: 1 cwd: /mnt/git/webkit-commit-queue/

Full output: http://queues.webkit.org/results/12072618
------- Comment #5 From 2012-03-21 16:04:49 PST -------
Created an attachment (id=133134) [details]
Patch for landing
------- Comment #6 From 2012-03-21 17:22:21 PST -------
(From update of attachment 133134 [details])
Rejecting attachment 133134 [details] from commit-queue.

Failed to run "['/mnt/git/webkit-commit-queue/Tools/Scripts/webkit-patch', '--status-host=queues.webkit.org', '-..." exit_code: 2

Last 500 characters of output:
hing file Source/JavaScriptCore/ChangeLog
Hunk #1 succeeded at 1 with fuzz 3.
patching file Source/JavaScriptCore/wtf/MetaAllocator.cpp
Hunk #1 succeeded at 47 with fuzz 2 (offset 14 lines).
patching file Source/JavaScriptCore/wtf/MetaAllocator.h
Hunk #1 FAILED at 196.
1 out of 1 hunk FAILED -- saving rejects to file Source/JavaScriptCore/wtf/MetaAllocator.h.rej

Failed to run "[u'/mnt/git/webkit-commit-queue/Tools/Scripts/svn-apply', u'--force']" exit_code: 1 cwd: /mnt/git/webkit-commit-queue/

Full output: http://queues.webkit.org/results/12066681
------- Comment #7 From 2012-03-21 17:31:24 PST -------
Landed in http://trac.webkit.org/changeset/111617.
------- Comment #8 From 2012-03-21 17:42:46 PST -------
(In reply to comment #7)
> Landed in http://trac.webkit.org/changeset/111617.

This change broke the TestWebKitAPI build. Two symbols are no longer exported:

WTF::MetaAllocator::~MetaAllocator()

    and

typeinfo for WTF::MetaAllocator

I can export the former by adding WTF_EXPORT_PRIVATE before its declaration in the header, but I don’t know how to export the latter.
------- Comment #9 From 2012-03-21 17:43:51 PST -------
(In reply to comment #8)
> (In reply to comment #7)
> > Landed in http://trac.webkit.org/changeset/111617.
> 
> This change broke the TestWebKitAPI build. Two symbols are no longer exported:
> 
> WTF::MetaAllocator::~MetaAllocator()
> 
>     and
> 
> typeinfo for WTF::MetaAllocator
> 
> I can export the former by adding WTF_EXPORT_PRIVATE before its declaration in the header, but I don’t know how to export the latter.

Probably WTF_EXPORTCLASS?  I dont' actually know.
------- Comment #10 From 2012-03-21 17:44:45 PST -------
The WTF/JSC exports are really a mistery to me, I'm currently runnig into issues tryign to bring up the JSC build after moving WTF locally due to our current export config.
------- Comment #11 From 2012-03-21 17:45:10 PST -------
(In reply to comment #8)
> (In reply to comment #7)
> > Landed in http://trac.webkit.org/changeset/111617.
> 
> This change broke the TestWebKitAPI build. Two symbols are no longer exported:

I assume I can test this locally on mac using "make"?
------- Comment #12 From 2012-03-21 17:49:43 PST -------
(In reply to comment #11)
> (In reply to comment #8)
> > (In reply to comment #7)
> > > Landed in http://trac.webkit.org/changeset/111617.
> > 
> > This change broke the TestWebKitAPI build. Two symbols are no longer exported:
> 
> I assume I can test this locally on mac using "make"?

Yes. If you can’t find out how to fix this soon, please revert r111617, so that tests can run again.
------- Comment #13 From 2012-03-21 17:52:55 PST -------
(In reply to comment #12)
> (In reply to comment #11)
> > (In reply to comment #8)
> > > (In reply to comment #7)
> > > > Landed in http://trac.webkit.org/changeset/111617.
> > > 
> > > This change broke the TestWebKitAPI build. Two symbols are no longer exported:
> > 
> > I assume I can test this locally on mac using "make"?
> 
> Yes. If you can’t find out how to fix this soon, please revert r111617, so that tests can run again.

Certainly.  I'm running "make" now.
------- Comment #14 From 2012-03-21 18:00:17 PST -------
(In reply to comment #11)
> (In reply to comment #8)
> > (In reply to comment #7)
> > > Landed in http://trac.webkit.org/changeset/111617.
> > 
> > This change broke the TestWebKitAPI build. Two symbols are no longer exported:
> 
> I assume I can test this locally on mac using "make"?

Hmm.  "make" resulted in:

** BUILD SUCCEEDED **

for me.  I guess I"ll try again with a clean build?
------- Comment #15 From 2012-03-21 18:14:12 PST -------
I fixed the problems in r111634.
------- Comment #16 From 2012-03-21 18:14:56 PST -------
Thank you.  I just got a reproduction. :)