Bug 80377

Summary: [BlackBerry] function rename issue after MediaPlayerPrivateBlackBerry.[cpp\h] upstream
Product: WebKit Reporter: Jonathan Dong <jonathan.dong.webkit>
Component: WebKit BlackBerryAssignee: Nobody <webkit-unassigned>
Severity: Normal CC: charles.wei, leoyang.webkit, rwlbuis, tonikitoo, webkit.review.bot
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Description Flags
Patch none

Description Jonathan Dong 2012-03-05 22:18:51 PST
As some of the function names changed in class MediaPlayerPrivate with the upstream of MediaPlayerPrivateBlackBerry.[cpp|h], we should update WebKit/blackberry/Api/WebPage.cpp which uses these functions accordingly.

renamed functions in MediaPlayerPrivate:
windowGet() -> getWindow()
windowPositionGet() -> getWindowPosition()
mmrContextNameGet() -> mmrContextName()
Comment 1 Jonathan Dong 2012-03-05 22:28:30 PST
Created attachment 130294 [details]
Comment 2 Rob Buis 2012-03-06 04:41:39 PST
Comment on attachment 130294 [details]

LGTM. But maybe window() instead of windowGet(), this would be more webkit style.
Comment 3 WebKit Review Bot 2012-03-06 04:59:53 PST
Comment on attachment 130294 [details]

Clearing flags on attachment: 130294

Committed r109907: <http://trac.webkit.org/changeset/109907>
Comment 4 WebKit Review Bot 2012-03-06 04:59:58 PST
All reviewed patches have been landed.  Closing bug.