Bug 80137

Summary: [EFL][DRT] Implements LayoutTestController's setPopupBlockingEnabled
Product: WebKit Reporter: Grzegorz Czajkowski <g.czajkowski>
Component: WebKit EFLAssignee: Nobody <webkit-unassigned>
Status: RESOLVED FIXED    
Severity: Normal CC: gyuyoung.kim, lucas.de.marchi, rakuco, webkit.review.bot
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Attachments:
Description Flags
proposed patch none

Description Grzegorz Czajkowski 2012-03-02 02:54:04 PST
Adds implementation LayoutTestController's setPopupBlockingEnabled.

I am working on this, patch will be uploaded.
Comment 1 Grzegorz Czajkowski 2012-03-06 00:33:19 PST
Created attachment 130314 [details]
proposed patch

This patch:
 - implements LayoutTestController's setPopupBlockingEnabled,
 - enables tests connected with setPopupBlockingEnabled
 - deletes idler which called by scheduleAsynchronousClickCallback (EventSender.cpp), sendClick should be called only once to pass popup-blocking-click-in-iframe.html
Comment 2 Raphael Kubo da Costa (:rakuco) 2012-03-06 04:57:41 PST
Comment on attachment 130314 [details]
proposed patch

Looks fine.
Comment 3 Gyuyoung Kim 2012-03-06 05:55:35 PST
Comment on attachment 130314 [details]
proposed patch

Looks good too.
Comment 4 Eric Seidel (no email) 2012-03-06 23:36:59 PST
Comment on attachment 130314 [details]
proposed patch

View in context: https://bugs.webkit.org/attachment.cgi?id=130314&action=review

LGTM.

> Tools/DumpRenderTree/efl/LayoutTestControllerEfl.cpp:439
> +void LayoutTestController::setPopupBlockingEnabled(bool flag)

Woudl be better to use a nicer name.  Like enablePopupBlocking.
Comment 5 Grzegorz Czajkowski 2012-03-06 23:53:44 PST
(In reply to comment #4)
> (From update of attachment 130314 [details])
> View in context: https://bugs.webkit.org/attachment.cgi?id=130314&action=review
> 
> LGTM.
> 
> > Tools/DumpRenderTree/efl/LayoutTestControllerEfl.cpp:439
> > +void LayoutTestController::setPopupBlockingEnabled(bool flag)
> 
> Woudl be better to use a nicer name.  Like enablePopupBlocking.

Yes, but this implements a common interface for all WebKit ports (Tools/DumpRenderTree/LayoutTestController.h) We can change it while general refactoring of DRT in my opinion :)
Comment 6 WebKit Review Bot 2012-03-06 23:54:51 PST
Comment on attachment 130314 [details]
proposed patch

Clearing flags on attachment: 130314

Committed r110028: <http://trac.webkit.org/changeset/110028>
Comment 7 WebKit Review Bot 2012-03-06 23:54:55 PST
All reviewed patches have been landed.  Closing bug.