Bug 80094

Summary: WorkerContext shouldn't know about IndexedDB
Product: WebKit Reporter: Adam Barth <abarth>
Component: New BugsAssignee: Adam Barth <abarth>
Status: RESOLVED FIXED    
Severity: Normal CC: eric, haraken, ojan, pilgrim, rakuco, vestbo, webkit.review.bot
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Bug Depends on:    
Bug Blocks: 79327    
Attachments:
Description Flags
Patch none

Description Adam Barth 2012-03-01 21:56:23 PST
WorkerContext shouldn't know about IndexedDB
Comment 1 Adam Barth 2012-03-01 21:58:34 PST
Created attachment 129809 [details]
Patch
Comment 2 Kentaro Hara 2012-03-01 22:07:22 PST
Comment on attachment 129809 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=129809&action=review

Wonderful cleanup!

> Source/WebCore/ChangeLog:14
> +        files were missing from various build systems, so I added them.  I
> +        suspect that means IndexedDB is only enabled by default on Chromium.

Yes, I think so.
Comment 3 WebKit Review Bot 2012-03-02 04:46:08 PST
Comment on attachment 129809 [details]
Patch

Clearing flags on attachment: 129809

Committed r109556: <http://trac.webkit.org/changeset/109556>
Comment 4 WebKit Review Bot 2012-03-02 04:46:13 PST
All reviewed patches have been landed.  Closing bug.
Comment 5 Mark Pilgrim (Google) 2012-03-16 08:15:53 PDT
*** Bug 79508 has been marked as a duplicate of this bug. ***