Bug 80071

Summary: Move WebCore/storage/IDB* files into WebCore/Modules/indexeddb
Product: WebKit Reporter: Adam Barth <abarth>
Component: New BugsAssignee: Adam Barth <abarth>
Status: RESOLVED FIXED    
Severity: Normal CC: commit-queue, eric, gustavo.noronha, gustavo, webkit.review.bot, xan.lopez
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Bug Depends on:    
Bug Blocks: 79327    
Attachments:
Description Flags
Patch
gyuyoung.kim: commit-queue-
Patch
none
Patch
none
Patch haraken: review+

Description Adam Barth 2012-03-01 16:52:00 PST
Move WebCore/storage/IDB* files into WebCore/Modules/indexeddb
Comment 1 Adam Barth 2012-03-01 16:56:07 PST
Created attachment 129775 [details]
Patch
Comment 2 Gyuyoung Kim 2012-03-01 17:16:05 PST
Comment on attachment 129775 [details]
Patch

Attachment 129775 [details] did not pass efl-ews (efl):
Output: http://queues.webkit.org/results/11769657
Comment 3 Adam Barth 2012-03-01 17:17:58 PST
Created attachment 129781 [details]
Patch
Comment 4 Build Bot 2012-03-01 17:26:47 PST
Comment on attachment 129775 [details]
Patch

Attachment 129775 [details] did not pass win-ews (win):
Output: http://queues.webkit.org/results/11751623
Comment 5 WebKit Commit Bot 2012-03-01 17:41:18 PST
Attachment 129781 [details] did not pass style-queue:

Failed to run "['Tools/Scripts/check-webkit-style', '--diff-files', u'Source/WebCore/CMakeLists.txt', u'Source/W..." exit_code: 1
Source/WebCore/Modules/indexeddb/IDBObjectStore.h:74:  The parameter name "key" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/WebCore/Modules/indexeddb/IDBBackingStore.h:47:  Missing space inside { }.  [whitespace/braces] [5]
Source/WebCore/Modules/indexeddb/IDBBackingStore.h:62:  Missing space inside { }.  [whitespace/braces] [5]
Source/WebCore/Modules/indexeddb/IDBBackingStore.h:76:  Missing space inside { }.  [whitespace/braces] [5]
Source/WebCore/Modules/indexeddb/IDBTransactionBackendImpl.h:51:  The parameter name "task" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/WebCore/Modules/indexeddb/IDBLevelDBBackingStore.cpp:514:  Missing space inside { }.  [whitespace/braces] [5]
Source/WebCore/Modules/indexeddb/IDBLevelDBBackingStore.cpp:1000:  Missing space inside { }.  [whitespace/braces] [5]
Source/WebCore/Modules/indexeddb/IDBCursorBackendInterface.h:47:  Missing space inside { }.  [whitespace/braces] [5]
Source/WebCore/Modules/indexeddb/IDBCursorBackendInterface.h:62:  The parameter name "key" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/WebCore/Modules/indexeddb/IDBObjectStoreBackendImpl.cpp:285:  Should have only a single space after a punctuation in a comment.  [whitespace/comments] [5]
Source/WebCore/Modules/indexeddb/IDBPendingTransactionMonitor.cpp:27:  You should add a blank line after implementation file's own header.  [build/include_order] [4]
Source/WebCore/Modules/indexeddb/IDBObjectStoreBackendImpl.h:69:  The parameter name "key" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/WebCore/Modules/indexeddb/IDBObjectStoreBackendImpl.h:79:  The parameter name "range" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/WebCore/Modules/indexeddb/IDBObjectStoreBackendImpl.h:92:  The parameter name "key" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/WebCore/Modules/indexeddb/IDBObjectStoreBackendImpl.h:98:  The parameter name "range" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/WebCore/Modules/indexeddb/IDBTransactionBackendInterface.h:54:  The parameter name "task" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/WebCore/Modules/indexeddb/IDBDatabase.cpp:33:  "EventQueue.h" already included at Source/WebCore/Modules/indexeddb/IDBDatabase.cpp:31  [build/include] [4]
Total errors found: 17 in 94 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 6 Build Bot 2012-03-01 17:44:02 PST
Comment on attachment 129781 [details]
Patch

Attachment 129781 [details] did not pass win-ews (win):
Output: http://queues.webkit.org/results/11751645
Comment 7 Gyuyoung Kim 2012-03-01 17:45:05 PST
Comment on attachment 129781 [details]
Patch

Attachment 129781 [details] did not pass efl-ews (efl):
Output: http://queues.webkit.org/results/11776708
Comment 8 Adam Barth 2012-03-01 17:55:29 PST
Created attachment 129784 [details]
Patch
Comment 9 Collabora GTK+ EWS bot 2012-03-01 18:06:51 PST
Comment on attachment 129784 [details]
Patch

Attachment 129784 [details] did not pass gtk-ews (gtk):
Output: http://queues.webkit.org/results/11757703
Comment 10 Adam Barth 2012-03-01 18:12:19 PST
Created attachment 129787 [details]
Patch
Comment 11 Eric Seidel (no email) 2012-03-01 18:45:54 PST
Comment on attachment 129787 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=129787&action=review

I assume you're just moving files and changing build systems?

> Source/WebCore/ChangeLog:15


You might consider running s/Copied/Moved/

> Source/WebCore/ChangeLog:105
> +        * storage/IDBAny.cpp: Removed.
> +        * storage/IDBAny.h: Removed.
> +        * storage/IDBAny.idl: Removed.

These double-entries are lame.
Comment 12 Eric Seidel (no email) 2012-03-01 18:46:12 PST
The EWSes are the real reviewers of patches like this. :p
Comment 13 Adam Barth 2012-03-01 18:58:12 PST
> I assume you're just moving files and changing build systems?

Correct.

> You might consider running s/Copied/Moved/

Will do.
Comment 14 WebKit Review Bot 2012-03-01 19:32:33 PST
Attachment 129787 [details] did not pass style-queue:

Failed to run "['Tools/Scripts/check-webkit-style', '--diff-files', u'Source/WebCore/CMakeLists.txt', u'Source/W..." exit_code: 1
Source/WebCore/Modules/indexeddb/IDBObjectStore.h:74:  The parameter name "key" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/WebCore/Modules/indexeddb/IDBBackingStore.h:47:  Missing space inside { }.  [whitespace/braces] [5]
Source/WebCore/Modules/indexeddb/IDBBackingStore.h:62:  Missing space inside { }.  [whitespace/braces] [5]
Source/WebCore/Modules/indexeddb/IDBBackingStore.h:76:  Missing space inside { }.  [whitespace/braces] [5]
Source/WebCore/Modules/indexeddb/IDBTransactionBackendImpl.h:51:  The parameter name "task" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/WebCore/Modules/indexeddb/IDBLevelDBBackingStore.cpp:514:  Missing space inside { }.  [whitespace/braces] [5]
Source/WebCore/Modules/indexeddb/IDBLevelDBBackingStore.cpp:1000:  Missing space inside { }.  [whitespace/braces] [5]
Source/WebCore/Modules/indexeddb/IDBCursorBackendInterface.h:47:  Missing space inside { }.  [whitespace/braces] [5]
Source/WebCore/Modules/indexeddb/IDBCursorBackendInterface.h:62:  The parameter name "key" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/WebCore/Modules/indexeddb/IDBObjectStoreBackendImpl.cpp:285:  Should have only a single space after a punctuation in a comment.  [whitespace/comments] [5]
Source/WebCore/Modules/indexeddb/IDBPendingTransactionMonitor.cpp:27:  You should add a blank line after implementation file's own header.  [build/include_order] [4]
Source/WebCore/Modules/indexeddb/IDBObjectStoreBackendImpl.h:69:  The parameter name "key" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/WebCore/Modules/indexeddb/IDBObjectStoreBackendImpl.h:79:  The parameter name "range" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/WebCore/Modules/indexeddb/IDBObjectStoreBackendImpl.h:92:  The parameter name "key" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/WebCore/Modules/indexeddb/IDBObjectStoreBackendImpl.h:98:  The parameter name "range" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/WebCore/Modules/indexeddb/IDBTransactionBackendInterface.h:54:  The parameter name "task" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/WebCore/Modules/indexeddb/IDBDatabase.cpp:33:  "EventQueue.h" already included at Source/WebCore/Modules/indexeddb/IDBDatabase.cpp:31  [build/include] [4]
Total errors found: 17 in 97 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 15 Kentaro Hara 2012-03-01 20:20:01 PST
Comment on attachment 129787 [details]
Patch

r=me. I guess you need to commit the patch manually to avoid style check errors. Please commit it after confirming the green face of the cr-linux ews.
Comment 16 Adam Barth 2012-03-01 20:21:41 PST
I've confirmed cr-mac and apple-mac locally.
Comment 17 Adam Barth 2012-03-01 20:23:34 PST
Committed r109493: <http://trac.webkit.org/changeset/109493>