Bug 80015

Summary: Make the tiling code slightly smarter
Product: WebKit Reporter: Kenneth Rohde Christiansen <kenneth>
Component: WebKit QtAssignee: Kenneth Rohde Christiansen <kenneth>
Severity: Normal CC: hausmann
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Description Flags
Patch none

Description Kenneth Rohde Christiansen 2012-03-01 01:29:15 PST
Avoid doing the same tranformations all over in each call to tileRectForCoordinate.

Do not resize tiles and then drop them because they are not out of the keep rect; instead drop before resizing.

Rename dropTilesOutsideRect to setKeepRect as it now stored the keep rect. This is used to avoid unneeded iteration of all tiles for invalidates outside the keep rect.
Comment 1 Kenneth Rohde Christiansen 2012-03-01 01:53:00 PST
Created attachment 129666 [details]
Comment 2 Kenneth Rohde Christiansen 2012-03-01 01:54:45 PST
Landed in 109327.