Bug 79813

Summary: Add size field to Metadata in FileSystem API
Product: WebKit Reporter: Kinuko Yasuda <kinuko>
Component: WebCore Misc.Assignee: Kinuko Yasuda <kinuko>
Status: RESOLVED FIXED    
Severity: Normal CC: abarth, dglazkov, ericu, fishd, levin, ojan, webkit.review.bot
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Attachments:
Description Flags
Patch
none
Patch none

Description Kinuko Yasuda 2012-02-28 11:12:09 PST
We should add size field to Metadata in FileSystem API as proposed in:
http://lists.w3.org/Archives/Public/public-webapps/2012JanMar/0905.html
Comment 1 Kinuko Yasuda 2012-02-28 16:29:23 PST
Created attachment 129352 [details]
Patch
Comment 2 David Levin 2012-02-28 16:56:03 PST
Comment on attachment 129352 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=129352&action=review

> Source/WebCore/fileapi/FileSystemCallbacks.cpp:34
> +#include <stdio.h>

Why include stdio?

> Source/WebCore/fileapi/Metadata.h:41
>  class Metadata : public RefCounted<Metadata> {

What is the differenence between Metadata and FileMetadata?

Metadata::m_metadata is confusing to me.

I guess Metadata is what is exposed to js code and FileMetadata is internal.

I wonder if m_metadata should be call m_internalMetadata. Slightly more verbose but at least you wouldn't have Metadata::m_metadata.
Comment 3 WebKit Review Bot 2012-02-28 17:38:57 PST
Comment on attachment 129352 [details]
Patch

Attachment 129352 [details] did not pass chromium-ews (chromium-xvfb):
Output: http://queues.webkit.org/results/11686064

New failing tests:
fast/filesystem/op-get-metadata.html
Comment 4 Kinuko Yasuda 2012-02-28 18:05:34 PST
Created attachment 129367 [details]
Patch
Comment 5 WebKit Review Bot 2012-02-28 18:11:21 PST
Attachment 129367 [details] did not pass style-queue:

Failed to run "['Tools/Scripts/check-webkit-style', '--diff-files', u'LayoutTests/ChangeLog', u'LayoutTests/fast..." exit_code: 1
Source/WebKit2/ChangeLog:1:  ChangeLog entry has no bug number  [changelog/bugnumber] [5]
WebKitLibraries/ChangeLog:1:  ChangeLog entry has no bug number  [changelog/bugnumber] [5]
WebKitLibraries/WebKitSystemInterface.h:339:  The parameter name "layer" adds no information, so it should be removed.  [readability/parameter_name] [5]
WebKitLibraries/WebKitSystemInterface.h:339:  The parameter name "context" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/WebKit/mac/ChangeLog:1:  ChangeLog entry has no bug number  [changelog/bugnumber] [5]
Total errors found: 5 in 17 files


If any of these errors are false positives, please file a bug against check-webkit-style.