Bug 78658

Summary: platformUserPreferredLanguages is leaking all of the language codes
Product: WebKit Reporter: Mark Rowe (bdash) <mrowe>
Component: PlatformAssignee: Mark Rowe (bdash) <mrowe>
Status: RESOLVED FIXED    
Severity: Normal CC: ap, eric.carlson, webkit.review.bot
Priority: P2 Keywords: InRadar, Regression
Version: 528+ (Nightly build)   
Hardware: Mac   
OS: Unspecified   
Attachments:
Description Flags
Patch v1 none

Description Mark Rowe (bdash) 2012-02-14 18:24:35 PST
createHTTPStyleLanguageCode returns a newly-allocated NSString. The caller does nothing to release this string, causing a leak.
Comment 1 Mark Rowe (bdash) 2012-02-14 18:29:44 PST
Created attachment 127097 [details]
Patch v1
Comment 2 Darin Adler 2012-02-14 18:33:09 PST
Comment on attachment 127097 [details]
Patch v1

I probably would have made even more of the code use String, but this looks like a fine fix. r=me
Comment 3 WebKit Review Bot 2012-02-14 19:05:03 PST
Comment on attachment 127097 [details]
Patch v1

Clearing flags on attachment: 127097

Committed r107771: <http://trac.webkit.org/changeset/107771>
Comment 4 WebKit Review Bot 2012-02-14 19:05:07 PST
All reviewed patches have been landed.  Closing bug.