Bug 78573

Summary: Rename Bump* to Copy*
Product: WebKit Reporter: Mark Hahnenberg <mhahnenberg@apple.com>
Component: JavaScriptCoreAssignee: Mark Hahnenberg <mhahnenberg@apple.com>
Status: RESOLVED FIXED    
Severity: Normal CC: barraclough@apple.com, eric@webkit.org, ggaren@apple.com, levin+threading@chromium.org, oliver@apple.com, rakuco@webkit.org, webkit.review.bot@gmail.com
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Bug Depends on:    
Bug Blocks: 78610    
Attachments:
Description Flags
Patch
none
Fix qt build ggaren: review+

Description From 2012-02-13 21:12:41 PST
In keeping with the naming theme of MarkedSpace et al, we should rename BumpSpace et al to CopySpace, etc.
------- Comment #1 From 2012-02-13 21:39:28 PST -------
Created an attachment (id=126905) [details]
Patch
------- Comment #2 From 2012-02-13 21:41:32 PST -------
Attachment 126905 [details] did not pass style-queue:

Failed to run "['Tools/Scripts/check-webkit-style', '--diff-files', u'Source/JavaScriptCore/CMakeLists.txt', u'S..." exit_code: 1

Source/JavaScriptCore/heap/Heap.h:43:  Code inside a namespace should not be indented.  [whitespace/indent] [4]
Total errors found: 1 in 19 files


If any of these errors are false positives, please file a bug against check-webkit-style.
------- Comment #3 From 2012-02-13 22:15:37 PST -------
Created an attachment (id=126907) [details]
Fix qt build
------- Comment #4 From 2012-02-13 22:18:58 PST -------
Attachment 126907 [details] did not pass style-queue:

Failed to run "['Tools/Scripts/check-webkit-style', '--diff-files', u'Source/JavaScriptCore/CMakeLists.txt', u'S..." exit_code: 1

Source/JavaScriptCore/heap/Heap.h:43:  Code inside a namespace should not be indented.  [whitespace/indent] [4]
Total errors found: 1 in 20 files


If any of these errors are false positives, please file a bug against check-webkit-style.
------- Comment #5 From 2012-02-16 16:53:45 PST -------
(From update of attachment 126907 [details])
I think the true analogue to "MarkedSpace" would actually be "CopiedSpace". Maybe you can make that change before committing.

rs=me
------- Comment #6 From 2012-02-17 12:09:29 PST -------
Committed r108107: <http://trac.webkit.org/changeset/108107>