Bug 78352

Summary: Rename [JSCustomGetOwnPropertySlotDelegate] to [JSCustomGetOwnPropertySlotAndDescriptor]
Product: WebKit Reporter: Kentaro Hara <haraken>
Component: WebCore JavaScriptAssignee: Kentaro Hara <haraken>
Severity: Normal CC: abarth, darin, japhet, ojan, webkit.review.bot
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Bug Depends on:    
Bug Blocks: 77393    
Description Flags
Patch none

Description Kentaro Hara 2012-02-10 05:03:42 PST
[JSCustomGetOwnPropertySlotDelegate] is used for "flexibly customizable" named getter. It allows us to write custom code for getOwnPropertySlotDelegate() and getOwnPropertyDescriptorDelegate(). To clarify that, we can rename [JSCustomGetOwnPropertySlotDelegate] to [JSCustomGetOwnPropertySlotAndDescriptor].
Comment 1 Kentaro Hara 2012-02-10 05:07:52 PST
Created attachment 126502 [details]
Comment 2 WebKit Review Bot 2012-02-10 13:03:30 PST
Comment on attachment 126502 [details]

Clearing flags on attachment: 126502

Committed r107432: <http://trac.webkit.org/changeset/107432>
Comment 3 WebKit Review Bot 2012-02-10 13:03:35 PST
All reviewed patches have been landed.  Closing bug.