Bug 78352 - Rename [JSCustomGetOwnPropertySlotDelegate] to [JSCustomGetOwnPropertySlotAndDescriptor]
Summary: Rename [JSCustomGetOwnPropertySlotDelegate] to [JSCustomGetOwnPropertySlotAnd...
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebCore JavaScript (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Kentaro Hara
Depends on:
Blocks: 77393
  Show dependency treegraph
Reported: 2012-02-10 05:03 PST by Kentaro Hara
Modified: 2012-02-10 13:03 PST (History)
5 users (show)

See Also:

Patch (8.92 KB, patch)
2012-02-10 05:07 PST, Kentaro Hara
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Kentaro Hara 2012-02-10 05:03:42 PST
[JSCustomGetOwnPropertySlotDelegate] is used for "flexibly customizable" named getter. It allows us to write custom code for getOwnPropertySlotDelegate() and getOwnPropertyDescriptorDelegate(). To clarify that, we can rename [JSCustomGetOwnPropertySlotDelegate] to [JSCustomGetOwnPropertySlotAndDescriptor].
Comment 1 Kentaro Hara 2012-02-10 05:07:52 PST
Created attachment 126502 [details]
Comment 2 WebKit Review Bot 2012-02-10 13:03:30 PST
Comment on attachment 126502 [details]

Clearing flags on attachment: 126502

Committed r107432: <http://trac.webkit.org/changeset/107432>
Comment 3 WebKit Review Bot 2012-02-10 13:03:35 PST
All reviewed patches have been landed.  Closing bug.