Bug 77424

Summary: [REGRESSION] Web Inspector: Can't open Web Inspector
Product: WebKit Reporter: Philippe Wittenbergh <phiw2>
Component: Web Inspector (Deprecated)Assignee: Timothy Hatcher <timothy>
Status: RESOLVED FIXED    
Severity: Normal CC: apavlov, ap, bweinstein, craigyk, joel, joepeck, jon, keishi, knavia, loislo, pfeldman, pmuellr, rik, timothy, webkit.review.bot, yurys
Priority: P1    
Version: 528+ (Nightly build)   
Hardware: All   
OS: All   
Attachments:
Description Flags
Proposed Change none

Description Philippe Wittenbergh 2012-01-31 04:24:42 PST
Neither Cmd-option-I, nor the menu item, nor a right click > Inspect element work. (the Menu item just blinks but nothing happens)

Regressed between r106204 and r106264
Comment 1 Philippe Wittenbergh 2012-01-31 04:25:35 PST
This is on OS X Lion 10.7.2, btw
Comment 2 Jon 2012-01-31 15:38:19 PST
I'm seeing this as well with the r106354 nightly and ToT.
Comment 3 Ryosuke Niwa 2012-01-31 15:38:51 PST
All regressions are P1.
Comment 4 Timothy Hatcher 2012-01-31 19:43:24 PST
This only happens in Release builds because the concatenated JavaScript file is failing with a syntax error.

file:///Users/Timothy/Work/Safari-TOT.git/OpenSource/WebKitBuild/Release/WebCore.framework/Resources/inspector/inspector.js:61427: JS ERROR: SyntaxError: Unexpected token ','

The parse error might happen in Debug builds to, but with less severe results because only a single file would fail and it might not be a critical one and the Inspector would continue to load.
Comment 5 Timothy Hatcher 2012-02-01 10:09:22 PST
*** Bug 77559 has been marked as a duplicate of this bug. ***
Comment 6 Timothy Hatcher 2012-02-01 10:35:56 PST
*** Bug 77561 has been marked as a duplicate of this bug. ***
Comment 7 Timothy Hatcher 2012-02-01 12:37:32 PST
*** Bug 77570 has been marked as a duplicate of this bug. ***
Comment 8 Timothy Hatcher 2012-02-01 13:03:16 PST
In debug it is this:

file:///Users/Timothy/Work/Safari-TOT.git/OpenSource/WebKitBuild/Release/WebCore.framework/Resources/inspector/DetailedHeapshotView.js:966: JS ERROR: SyntaxError: Unexpected token ','

This is a file Safari does not use, but the error is causing problems in release.

I have a fix.
Comment 9 Timothy Hatcher 2012-02-01 13:10:59 PST
Created attachment 124999 [details]
Proposed Change
Comment 10 WebKit Review Bot 2012-02-01 15:08:30 PST
Comment on attachment 124999 [details]
Proposed Change

Clearing flags on attachment: 124999

Committed r106501: <http://trac.webkit.org/changeset/106501>
Comment 11 WebKit Review Bot 2012-02-01 15:08:35 PST
All reviewed patches have been landed.  Closing bug.