Bug 7685

Summary: Focus ring color should change to match graphite when system theme is graphite
Product: WebKit Reporter: mitz@webkit.org <mitz@webkit.org>
Component: Layout and RenderingAssignee: Darin Adler <darin@apple.com>
Status: VERIFIED FIXED    
Severity: Normal    
Priority: P1    
Version: 420+   
Hardware: Macintosh   
OS: Mac OS X 10.4   

Description From 2006-03-09 15:09:02 PST
When the Graphite appearance is selected in System Preferences, contenteditable elements' focus rings should be graphite by default rather than blue.

Currently the default focus ring color comes from html4.css:
:focus { 
    outline: auto 3px #1f5ccf
}

This rule should change dynamically to match the selection in System Preferences.
------- Comment #1 From 2006-03-09 15:24:58 PST -------
Supporting Graphite well has not been a high priority lately, but I agree completely that this change would be a correct one. The system's focus ring color does change to a gray color when Graphite has been selected.
------- Comment #2 From 2006-03-10 01:11:33 PST -------
Just need a special keyword for the color, e.g., -khtml-focus-ring-color
------- Comment #3 From 2006-03-10 01:11:38 PST -------
Just need a special keyword for the color, e.g., -khtml-focus-ring-color
------- Comment #4 From 2006-03-29 17:51:08 PST -------
Bumping to P1 since this causes a text field regression
------- Comment #5 From 2006-04-01 22:12:01 PST -------
The patch I am about to attach to bug 8123 fixes this bug as well.
------- Comment #6 From 2006-04-04 01:54:15 PST -------
Verified in r13675 nightly.