Bug 76566

Summary: [Qt] REGRESSION(r105310): Two inspector tests fails
Product: WebKit Reporter: Csaba Osztrogonác <ossy>
Component: Tools / TestsAssignee: Nobody <webkit-unassigned>
Status: RESOLVED FIXED    
Severity: Normal CC: kadam, ossy, vsevik
Priority: P2 Keywords: Qt, QtTriaged
Version: 528+ (Nightly build)   
Hardware: All   
OS: All   
Bug Depends on:    
Bug Blocks: 73099, 79666    

Description Csaba Osztrogonác 2012-01-18 13:55:29 PST
After http://trac.webkit.org/changeset/105310 two inspector tests fail:

http/tests/inspector/console-cross-origin-iframe-logging.html is new test:
--- /ramdisk/qt-linux-64-release/build/layout-test-results/http/tests/inspector/console-cross-origin-iframe-logging-expected.txt 
+++ /ramdisk/qt-linux-64-release/build/layout-test-results/http/tests/inspector/console-cross-origin-iframe-logging-actual.txt 
@@ -4,13 +4,7 @@
 
 CONSOLE MESSAGE: Unable to post message to http://127.0.0.1:8000. Recipient has origin http://localhost:8000.
 
+FAIL: Timed out waiting for notifyDone to be called
 Tests that cross origin errors are logged with source url and line number.
 
 
-Unsafe JavaScript attempt to access frame with URL http://localhost:8000/inspector/resources/cross-origin-iframe.html from frame with URL http://127.0.0.1:8000/inspector/console-cross-origin-iframe-logging.html. Domains, protocols and ports must match.
-
-Unsafe JavaScript attempt to access frame with URL http://localhost:8000/inspector/resources/cross-origin-iframe.html from frame with URL http://127.0.0.1:8000/inspector/console-cross-origin-iframe-logging.html. Domains, protocols and ports must match.
-
-Unable to post message to http://127.0.0.1:8000. Recipient has origin http://localhost:8000.
-
-

http/tests/inspector/console-resource-errors.html is old test:
--- /ramdisk/qt-linux-64-release/build/layout-test-results/http/tests/inspector/console-resource-errors-expected.txt 
+++ /ramdisk/qt-linux-64-release/build/layout-test-results/http/tests/inspector/console-resource-errors-actual.txt 
@@ -1,6 +1,7 @@
 Tests that errors to load a resource cause error messages to be logged to console.
 
 
+XHR finished loading: "http://127.0.0.1:8000/inspector/non-existent-xhr". console-message console-log-level
 console-resource-errors-iframe.html:3GET http://127.0.0.1:8000/inspector/missing.css 404 (Not Found) console-message console-error-level
 console-resource-errors-iframe.html:4GET http://127.0.0.1:8000/inspector/non-existent-script.js 404 (Not Found) console-message console-error-level
 non-existent-iframe.html:1GET http://127.0.0.1:8000/inspector/non-existent-iframe.html 404 (Not Found) console-message console-error-level
Comment 1 Csaba Osztrogonác 2012-01-18 13:59:01 PST
I skipped the new failing tests to paint the bots green: http://trac.webkit.org/changeset/105317
Comment 2 Vsevolod Vlasov 2012-01-19 07:12:48 PST
Unskipped http/tests/inspector/console-resource-errors.html as its failure was side effect of http/tests/inspector/console-cross-origin-iframe-logging.html failure.

Committed r105411: <http://trac.webkit.org/changeset/105411>
Comment 3 Csaba Osztrogonác 2012-02-27 08:08:14 PST
(In reply to comment #2)
> Unskipped http/tests/inspector/console-resource-errors.html as its failure was side effect of http/tests/inspector/console-cross-origin-iframe-logging.html failure.
> 
> Committed r105411: <http://trac.webkit.org/changeset/105411>

Thanks. Is there a bug report to make http/tests/inspector/console-cross-origin-iframe-logging.html not cause sideeffect?
Comment 4 Vsevolod Vlasov 2012-02-27 10:14:51 PST
I am sorry, I closed that by mistake.
http/tests/inspector/console-cross-origin-iframe-logging.html is not yet fixed.
Comment 5 Ádám Kallai 2012-09-26 01:30:33 PDT
I'm reviewing old bugs. Is it a valid bug? Because I got the other result. It's possible that Is it a correct result on Qt? Could you check it please?

--- /home/kadam/webkit/WebKit/WebKitBuild/Release/layout-test-results/http/tests/inspector/console-cross-origin-iframe-logging-expected.txt
+++ /home/kadam/webkit/WebKit/WebKitBuild/Release/layout-test-results/http/tests/inspector/console-cross-origin-iframe-logging-actual.txt
@@ -8,9 +8,9 @@
 
 
 Unsafe JavaScript attempt to access frame with URL http://localhost:8000/inspector/resources/cross-origin-iframe.html from frame with URL http://127.0.0.1:8000/inspector/console-cross-origin-iframe-logging.html. Domains, protocols and ports must match.
+ console-cross-origin-iframe-logging.html:9
+Unsafe JavaScript attempt to access frame with URL http://localhost:8000/inspector/resources/cross-origin-iframe.html from frame with URL http://127.0.0.1:8000/inspector/console-cross-origin-iframe-logging.html. Domains, protocols and ports must match.
+ [native code]:1
+Unable to post message to http://127.0.0.1:8000. Recipient has origin http://localhost:8000.
+ [native code]:1
 
-Unsafe JavaScript attempt to access frame with URL http://localhost:8000/inspector/resources/cross-origin-iframe.html from frame with URL http://127.0.0.1:8000/inspector/console-cross-origin-iframe-logging.html. Domains, protocols and ports must match.
-
-Unable to post message to http://127.0.0.1:8000. Recipient has origin http://localhost:8000.
-
-
Comment 6 Vsevolod Vlasov 2012-09-26 02:04:43 PDT
This is a correct result.
Comment 7 Ádám Kallai 2012-09-26 02:31:13 PDT
Thanks for your help. I'm going to remove to the skipped list.
Comment 8 Vsevolod Vlasov 2012-09-27 02:41:54 PDT
Committed r129744: <http://trac.webkit.org/changeset/129744>