Bug 76175

Summary: [Qt][WK2][Mac] Conflict of MacTypes.h defining a Fixed type after r104560.
Product: WebKit Reporter: Zeno Albisser <zeno>
Component: WebKit QtAssignee: Zeno Albisser <zeno>
Status: RESOLVED DUPLICATE    
Severity: Normal CC: ossy
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Attachments:
Description Flags
compile log.
none
patch for review. none

Description Zeno Albisser 2012-01-12 07:13:41 PST
MacTypes.h definition of "Fixed" collides with WebCore/platform/Length.h.
See attached log.
Comment 1 Zeno Albisser 2012-01-12 07:19:06 PST
Created attachment 122237 [details]
compile log.
Comment 2 Zeno Albisser 2012-01-12 07:20:07 PST
Created attachment 122238 [details]
patch for review.
Comment 3 Zeno Albisser 2012-01-12 07:28:57 PST
Comment on attachment 122238 [details]
patch for review.

Clearing flags on attachment: 122238

Committed r104826: <http://trac.webkit.org/changeset/104826>
Comment 4 Zeno Albisser 2012-01-12 07:29:06 PST
All reviewed patches have been landed.  Closing bug.
Comment 5 Csaba Osztrogon√°c 2012-01-13 04:08:03 PST
Reopen, because it broke the build on our SL bot on http://build.webkit.org .
( But it's strange for me, because the build works on the other SL bot on http://build.webkit.sed.hu )

Could you check it?
Comment 6 Zeno Albisser 2012-01-20 07:01:02 PST

*** This bug has been marked as a duplicate of bug 76340 ***