Bug 73986

Summary: change function name InitializeLoggingChannelsIfNecessary to follow coding style guideline
Product: WebKit Reporter: Mary Wu <mawu>
Component: WebKit Misc.Assignee: Nobody <webkit-unassigned>
Severity: Normal CC: dbates, jberlin, leo.yang, tonikitoo, webkit.review.bot
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Description Flags
Patch none

Description Mary Wu 2011-12-07 00:04:08 PST
According to WebKit coding style guideline "Lower-case the first letter, including all letters in an acronym, in a variable or function name",
but the function name InitializeLoggingChannelsIfNecessary in the file WebCore/platform/Logging.h break the rule. We need to change the name
to initializeLoggingChannelsIfNecessary in the header file and all its porting implementations.
Comment 1 Mary Wu 2011-12-07 00:08:21 PST
Created attachment 118176 [details]
Comment 2 Mary Wu 2011-12-07 00:16:35 PST
Created attachment 118177 [details]
Comment 3 Leo Yang 2011-12-07 02:19:36 PST
Comment 4 WebKit Review Bot 2011-12-07 06:54:29 PST
Comment on attachment 118177 [details]

Clearing flags on attachment: 118177

Committed r102235: <http://trac.webkit.org/changeset/102235>
Comment 5 WebKit Review Bot 2011-12-07 06:54:34 PST
All reviewed patches have been landed.  Closing bug.
Comment 6 Jessie Berlin 2011-12-07 08:15:12 PST
FYI, this change broke the Mac build because you did not update the name in the WebCore.exp.in file. Fixed in http://trac.webkit.org/changeset/102241
Comment 7 Mary Wu 2011-12-07 18:18:56 PST
thanks for the fix, Jessie