Bug 73024

Summary: Web Inspector: get rid of the WebInspector.mainResource, use WebInspector.inspectedPageURL instead.
Product: WebKit Reporter: Pavel Feldman <pfeldman>
Component: Web Inspector (Deprecated)Assignee: Pavel Feldman <pfeldman>
Status: RESOLVED FIXED    
Severity: Normal CC: apavlov, bweinstein, joepeck, keishi, loislo, pfeldman, pmuellr, rik, timothy, yurys
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: All   
OS: All   
Attachments:
Description Flags
Patch yurys: review+

Pavel Feldman
Reported 2011-11-23 09:14:27 PST
We use it for the URL mostly, no need to create artificial resource for that upon attaching to the existing page.
Attachments
Patch (25.20 KB, patch)
2011-11-23 09:17 PST, Pavel Feldman
yurys: review+
Pavel Feldman
Comment 1 2011-11-23 09:17:09 PST
Yury Semikhatsky
Comment 2 2011-11-23 09:26:01 PST
Comment on attachment 116373 [details] Patch View in context: https://bugs.webkit.org/attachment.cgi?id=116373&action=review > Source/WebCore/inspector/front-end/AuditsPanel.js:135 > + var mainResourceURL = WebInspector.inspectedPageURL; I don't think inspectedPageUrl is a good name, it will be confusing in case of worker inspector, could you rename it to mainResourceURL or something like that? Same for inspectedPageDomain
Vsevolod Vlasov
Comment 3 2011-11-23 17:35:28 PST
Comment on attachment 116373 [details] Patch View in context: https://bugs.webkit.org/attachment.cgi?id=116373&action=review > Source/WebCore/inspector/front-end/NetworkPanel.js:986 > + InspectorFrontendHost.saveAs(WebInspector.inspectedPageURL.asParsedURL().host + ".har", JSON.stringify(harArchive)); s/WebInspector.inspectedPageURL.asParsedURL().host/WebInspector.inspectedPageDomain/
Pavel Feldman
Comment 4 2011-11-24 00:11:26 PST
Note You need to log in before you can comment on or make changes to this bug.