Bug 71734

Summary: The Full Keyboard Access preference should be read in the UI process
Product: WebKit Reporter: Alexey Proskuryakov <ap>
Component: WebKit2Assignee: Alexey Proskuryakov <ap>
Status: RESOLVED FIXED    
Severity: Normal Keywords: InRadar
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Attachments:
Description Flags
proposed patch darin: review+

Alexey Proskuryakov
Reported 2011-11-07 14:23:18 PST
That would let us tighten the sandbox a bit. Also, that's what we do for other global preferences. <rdar://problem/9237619>
Attachments
proposed patch (30.21 KB, patch)
2011-11-07 14:33 PST, Alexey Proskuryakov
darin: review+
Alexey Proskuryakov
Comment 1 2011-11-07 14:33:04 PST
Created attachment 113931 [details] proposed patch
Darin Adler
Comment 2 2011-11-07 14:41:38 PST
Comment on attachment 113931 [details] proposed patch View in context: https://bugs.webkit.org/attachment.cgi?id=113931&action=review > Source/WebKit2/WebProcess/WebProcess.h:99 > + bool fullKeyboardAccessEnabled() { return m_fullKeyboardAccessEnabled; } Maybe make this const? > Source/WebKit2/WebProcess/WebProcess.h:146 > + void fullKeyboardAccessModeChanged(bool mode); The word “mode” is not a great name for this argument. Maybe “fullKeyboardAcessEabled”? I’m not sure that xxxChanged is a great name for something that just sets the mode. I think setFullKeyboardAccessEnabled is a better name.
Alexey Proskuryakov
Comment 3 2011-11-07 14:53:31 PST
Committed <http://trac.webkit.org/changeset/99483>. > Maybe make this const? Done. > The word “mode” is not a great name for this argument. Maybe “fullKeyboardAcessEabled”? Done. > I’m not sure that xxxChanged is a great name for something that just sets the mode. I think setFullKeyboardAccessEnabled is a better name. I agree that it's slightly better from WebProcess perspective. However, I wanted to keep it consistent with LanguageChanged.
Note You need to log in before you can comment on or make changes to this bug.