Bug 71723

Summary: Change /usr/bin/python to /usr/bin/python2 in python scripts
Product: WebKit Reporter: Rafael Antognolli <antognolli+webkit>
Component: Tools / TestsAssignee: Nobody <webkit-unassigned>
Status: RESOLVED DUPLICATE    
Severity: Normal CC: eric
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: PC   
OS: Linux   

Description Rafael Antognolli 2011-11-07 12:56:25 PST
Many python scripts are written for use with python2, but they have
 #!/usr/bin/python

in the beginning of the script. For instance, the script WebKit/Source/WebCore/inspector/CodeGeneratorInspector.py has this problem. But in some linux distributions, /usr/bin/python already points to python 3 instead of python 2, thus the script is incompatible.

There are some discussions already about making it a standard to have /usr/bin/python2 in the system, like here: http://mail.python.org/pipermail/python-dev/2011-March/108571.html

So, could we make this change on our scripts? (I can file a patch making that sed if people agree)

Regards,
Rafael
Comment 1 Eric Seidel (no email) 2011-11-07 13:12:37 PST
We should just fix our scripts to support Python 3 (if possible).

python2 doesn't exist on Macs.
Comment 2 Eric Seidel (no email) 2011-11-07 13:13:14 PST

*** This bug has been marked as a duplicate of bug 55037 ***