Bug 69446

Summary: Use std::reverse_iterator for ListHashSet reverse iterators
Product: WebKit Reporter: Anders Carlsson <andersca>
Component: Web Template FrameworkAssignee: Anders Carlsson <andersca>
Status: REOPENED ---    
Severity: Normal CC: darin, rniwa, webkit.review.bot
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Bug Depends on: 69454    
Bug Blocks:    
Attachments:
Description Flags
Patch darin: review+, dbates: commit-queue-

Description Anders Carlsson 2011-10-05 11:23:09 PDT
Use std::reverse_iterator for ListHashSet reverse iterators
Comment 1 Anders Carlsson 2011-10-05 11:24:27 PDT
Created attachment 109827 [details]
Patch
Comment 2 Darin Adler 2011-10-05 11:26:01 PDT
Comment on attachment 109827 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=109827&action=review

Did you test this? Does it work?

> Source/JavaScriptCore/ChangeLog:13
> +        (WTF::::rbegin):
> +        (WTF::::rend):

You should remove these garbled lines from the change log.
Comment 3 WebKit Review Bot 2011-10-05 11:27:04 PDT
Attachment 109827 [details] did not pass style-queue:

Failed to run "['Tools/Scripts/check-webkit-style', '--diff-files', u'Source/JavaScriptCore/ChangeLog', u'Source..." exit_code: 1

Source/JavaScriptCore/wtf/ListHashSet.h:80:  reverse_iterator is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
Source/JavaScriptCore/wtf/ListHashSet.h:81:  const_reverse_iterator is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
Source/JavaScriptCore/wtf/ListHashSet.h:274:  iterator_category is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
Source/JavaScriptCore/wtf/ListHashSet.h:275:  value_type is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
Source/JavaScriptCore/wtf/ListHashSet.h:278:  difference_type is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
Source/JavaScriptCore/wtf/ListHashSet.h:328:  iterator_category is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
Source/JavaScriptCore/wtf/ListHashSet.h:329:  value_type is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
Source/JavaScriptCore/wtf/ListHashSet.h:332:  difference_type is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
Total errors found: 8 in 2 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 4 Anders Carlsson 2011-10-05 11:28:55 PDT
Committed r96733: <http://trac.webkit.org/changeset/96733>
Comment 6 Darin Adler 2011-10-05 12:50:49 PDT
Apparently on older toolsets, <iterator> is not compatible with -fno-exceptions.
Comment 7 Darin Adler 2011-10-05 12:52:14 PDT
Maybe not practical if we support those old Mac toolsets?
Comment 8 Anders Carlsson 2011-10-05 13:30:10 PDT
(In reply to comment #7)
> Maybe not practical if we support those old Mac toolsets?

It seems to me like if we include something that ends up including exception_defines.h we should be fine - it contains macros that define away try/catch.
Comment 9 Daniel Bates 2011-10-16 04:17:10 PDT
Comment on attachment 109827 [details]
Patch

Attachment 109827 [details] did not pass mac-ews (mac):
Output: http://queues.webkit.org/results/10073612