Bug 66682

Summary: garden-o-matic's relative time display should be updated regularly.
Product: WebKit Reporter: Dimitri Glazkov (Google) <dglazkov>
Component: Tools / TestsAssignee: Dimitri Glazkov (Google) <dglazkov>
Status: RESOLVED FIXED    
Severity: Normal CC: abarth
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Bug Depends on:    
Bug Blocks: 64188    
Attachments:
Description Flags
Patch abarth: review+

Description Dimitri Glazkov (Google) 2011-08-22 10:24:28 PDT
garden-o-matic's relative time display should be updated regularly.
Comment 1 Dimitri Glazkov (Google) 2011-08-22 10:25:44 PDT
Created attachment 104693 [details]
Patch
Comment 2 Adam Barth 2011-08-22 10:45:18 PDT
Comment on attachment 104693 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=104693&action=review

> Tools/BuildSlaveSupport/build.webkit.org-config/public_html/TestFailures/scripts/ui.js:30
> +var kTimeUpdateFrequencyInMilliseconds = 1000;

Should this be in config ?

> Tools/BuildSlaveSupport/build.webkit.org-config/public_html/TestFailures/scripts/ui.js:183
> +    Array.prototype.forEach.call(document.querySelectorAll("time"), function(time) {

Do we want to add a class name here?  It seems like we could use other <time> elements that don't derive from ui.Time
Comment 3 Dimitri Glazkov (Google) 2011-08-22 10:58:05 PDT
Comment on attachment 104693 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=104693&action=review

>> Tools/BuildSlaveSupport/build.webkit.org-config/public_html/TestFailures/scripts/ui.js:30
>> +var kTimeUpdateFrequencyInMilliseconds = 1000;
> 
> Should this be in config ?

Ooh, yes.

>> Tools/BuildSlaveSupport/build.webkit.org-config/public_html/TestFailures/scripts/ui.js:183
>> +    Array.prototype.forEach.call(document.querySelectorAll("time"), function(time) {
> 
> Do we want to add a class name here?  It seems like we could use other <time> elements that don't derive from ui.Time

That's a neat idea! I'll add "relative" to the instance. Hey, I should even rename this to RelativeTime class.
Comment 4 Dimitri Glazkov (Google) 2011-08-22 11:15:56 PDT
Committed r93522: <http://trac.webkit.org/changeset/93522>