Bug 66121
Summary: | Rename GraphicsContextGL::paintToCanvas() to a more generic name | ||
---|---|---|---|
Product: | WebKit | Reporter: | John Bauman <jbauman> |
Component: | Canvas | Assignee: | Nobody <webkit-unassigned> |
Status: | REOPENED | ||
Severity: | Normal | CC: | annevk, bfulgham, cmarrin, guanqun.lu, jamesr, kbr, mdelaney7, sabouhallawa |
Priority: | P2 | Keywords: | DoNotImportToRadar |
Version: | 528+ (Nightly build) | ||
Hardware: | Unspecified | ||
OS: | Unspecified |
John Bauman
This is referenced in GraphicsContext3D::paintRenderingResultsToCanvas, which is a layering violation. It would be pretty easy to replace this with the canvas's ImageBuffer in these circumstances.
Attachments | ||
---|---|---|
Add attachment proposed patch, testcase, etc. |
Anne van Kesteren
I can no longer find that method.
Said Abou-Hallawa
GraphicsContext3D was renamed to GraphicsContextGL in 218939@main.
But GraphicsContextGL still has a static method called GraphicsContextGL::paintToCanvas(). This method does not do anything specific to the canvas or to the GraphicsContextGL itself. It just draws a NativeImage to a GraphicsContext.
I think function should be removed from this class and should be renamed to a more generic name.
Also this function has this code which I think is valid only for Cocoa platforms:
GraphicsContextStateSaver stateSaver(context);
context.scale(FloatSize(1, -1));
context.translate(0, -imageSize.height());