Bug 65252

Summary: [GTK] Copy and paste is broken in WebKit2
Product: WebKit Reporter: Carlos Garcia Campos <cgarcia@igalia.com>
Component: WebKit2Assignee: Nobody <webkit-unassigned@lists.webkit.org>
Status: RESOLVED FIXED    
Severity: Normal CC: l.slachciak@samsung.com
Priority: P2 Keywords: Gtk
Version: 528+ (Nightly build)   
Hardware: PC   
OS: Linux   
Attachments:
Description Flags
Patch mrobinson: review+

Description From 2011-07-27 06:24:16 PST
The problem is that PasteboardHelper uses page client widget to get the GtkClipboard.
------- Comment #1 From 2011-07-27 06:29:52 PST -------
Created an attachment (id=102139) [details]
Patch

Use gtk_clipboard_get_for_display() instead of gtk_widget_get_clipboard().
------- Comment #2 From 2011-07-27 19:30:04 PST -------
(From update of attachment 102139 [details])
Seems reasonable.
------- Comment #3 From 2011-07-28 08:22:55 PST -------
Committed r91929: <http://trac.webkit.org/changeset/91929>