Bug 61990

Summary: Rename HTMLInputElement::m_value to m_valueIfDirty
Product: WebKit Reporter: Keishi Hattori <keishi>
Component: FormsAssignee: Keishi Hattori <keishi>
Status: RESOLVED FIXED    
Severity: Normal CC: ap, tkent, webkit.review.bot
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Attachments:
Description Flags
patch
none
fixed typo none

Description Keishi Hattori 2011-06-02 20:43:34 PDT
Discussed in Bug 61857.

HTMLInputElement::m_value only contain the value of the element when the dirty value flag is true. Otherwise the value is taken from the "value" attribute. 

It should be renamed because it is confusing.
Comment 1 Keishi Hattori 2011-06-02 20:55:47 PDT
Created attachment 95849 [details]
patch
Comment 2 Kent Tamura 2011-06-02 21:02:39 PDT
Comment on attachment 95849 [details]
patch

View in context: https://bugs.webkit.org/attachment.cgi?id=95849&action=review

> Source/WebCore/html/HTMLInputElement.h:142
> +    bool hadDirtyValue() const { return !m_valueIfDirty.isNull(); };

Why 'had'?  I think it should be 'has'.
Comment 3 Keishi Hattori 2011-06-02 21:06:47 PDT
Created attachment 95851 [details]
fixed typo
Comment 4 Keishi Hattori 2011-06-02 21:07:31 PDT
> Why 'had'?  I think it should be 'has'.

Sorry, typo.
Comment 5 Kent Tamura 2011-06-02 21:17:55 PDT
Comment on attachment 95851 [details]
fixed typo

ok
Comment 6 WebKit Review Bot 2011-06-07 23:19:02 PDT
Comment on attachment 95851 [details]
fixed typo

Clearing flags on attachment: 95851

Committed r88329: <http://trac.webkit.org/changeset/88329>
Comment 7 WebKit Review Bot 2011-06-07 23:19:06 PDT
All reviewed patches have been landed.  Closing bug.