Bug 61342

Summary: Regression(r87118): chromium/mac: scroll layout tests failures
Product: WebKit Reporter: Fumitoshi Ukai <ukai>
Component: Layout and RenderingAssignee: Nobody <webkit-unassigned>
Status: RESOLVED WONTFIX    
Severity: Normal CC: jamesr, sail, thakis
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Attachments:
Description Flags
Patch
none
Patch tony: review-

Description Fumitoshi Ukai 2011-05-23 21:50:00 PDT
Since r87118, chromium/mac started failing layout tests of scroll.

fast/repaint/fixed-move-after-keyboard-scroll.html = IMAGE+TEXT
fast/dom/vertical-scrollbar-in-rtl.html = TEXT
fast/events/node-event-anchor-lock.html = TEXT
fast/events/scroll-after-click-on-tab-index.html = TEXT
fast/events/scrollbar-double-click.html = TEXT

http://test-results.appspot.com/dashboards/flakiness_dashboard.html#group=%40ToT%20-%20chromium.org&tests=fast%2Frepaint%2Ffixed-move-after-keyboard-scroll.html%2Cfast%2Fdom%2Fvertical-scrollbar-in-rtl.html%2Cfast%2Fevents%2Fnode-event-anchor-lock.html%2Cfast%2Fevents%2Fscroll-after-click-on-tab-index.html%2Cfast%2Fevents%2Fscrollbar-double-click.html
Comment 1 Sailesh Agrawal 2011-05-24 08:33:45 PDT
Sorry for breaking the tests. Adding relevant links:
http://trac.webkit.org/changeset/87126
http://trac.webkit.org/changeset/87130
Comment 2 Sailesh Agrawal 2011-05-24 11:08:01 PDT
Hi Ukai, I can't reproduce the test failure. All 5 tests pass for me.
Comment 3 Sailesh Agrawal 2011-05-24 16:00:20 PDT
CCing jamesr and thakis in case there's something I should be doing that I'm not.
Comment 4 James Robinson 2011-05-24 16:03:34 PDT
(In reply to comment #3)
> CCing jamesr and thakis in case there's something I should be doing that I'm not.

Well, what are you doing?
Comment 5 Sailesh Agrawal 2011-05-24 16:04:58 PDT
I ran:
   Tools/Scripts/new-run-webkit-tests --debug --chromium
on tip of tree with and without my change and it passes. Not sure how to reproduce the failure from the dashboard link.
Comment 6 Sailesh Agrawal 2011-05-25 15:17:28 PDT
Created attachment 94868 [details]
Patch
Comment 7 Sailesh Agrawal 2011-05-25 15:18:40 PDT
I've updated a new patch that re-adds the reverted code. The patch contains the following additional changes:
- remove text exceptions
- disable smooth scrolling in ScrollAnimatorChroimiumMac::scroll()
Comment 8 Sailesh Agrawal 2011-05-26 13:32:09 PDT
Created attachment 95028 [details]
Patch
Comment 9 Sailesh Agrawal 2011-05-26 13:34:29 PDT
Scroll tests no loger fail on the try bots with this patch:
http://build.chromium.org/p/tryserver.chromium/builders/mac_layout_rel/builds/194
For comparison here's the output from the try bot with an empty change list:
http://build.chromium.org/p/tryserver.chromium/builders/mac_layout_rel/builds/191
Comment 10 Sailesh Agrawal 2011-05-26 13:41:51 PDT
Here's the result for my patch on the mac_layout bot:
http://build.chromium.org/p/tryserver.chromium/builders/mac_layout/builds/633
Comment 11 Tony Chang 2011-05-26 13:51:14 PDT
Comment on attachment 95028 [details]
Patch

I suggest you reopen bug 59753 and post this patch there with the change description from your original patch.  I would include what changes you made since the first time this patch landed (to make the review easier).  I would also ask jamesr to review the change since he gave the original r+.
Comment 12 Stephen Chenney 2013-04-09 16:10:55 PDT
LayoutTest failures for Chromium are being marked WontFix. The Bug is still accessible and referenced from TestExpectations.