Bug 61237

Summary: Web Inspector: [V8] [REGRESSION=r86837] evaluating syntax error in the console crashes the page.
Product: WebKit Reporter: Pavel Feldman <pfeldman>
Component: Web Inspector (Deprecated)Assignee: Nobody <webkit-unassigned>
Status: RESOLVED DUPLICATE    
Severity: Normal CC: abarth, yurys
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: All   
OS: All   

Description Pavel Feldman 2011-05-20 22:43:44 PDT
Evaluate "(" in the console.

0028f180 6d93c2ad chrome_6d750000!v8::Script::Run+0xed [d:\b\build\slave\chrome-official\build\src\v8\src\api.cc @ 1478]
0028f190 6e62b3a5 chrome_6d750000!WebCore::V8InjectedScriptHost::evaluateCallback+0x88 [d:\b\build\slave\chrome-official\build\src\third_party\webkit\source\webcore\bindings\v8\custom\v8injectedscripthostcustom.cpp @ 79]
0028f1f4 6e62b773 chrome_6d750000!v8::internal::HandleApiCallHelper<0>+0x195 [d:\b\build\slave\chrome-official\build\src\v8\src\builtins.cc @ 1129]
0028f200 2fe200b6 chrome_6d750000!v8::internal::Builtin_HandleApiCall+0x13 [d:\b\build\slave\chrome-official\build\src\v8\src\builtins.cc @ 1145]
WARNING: Frame IP not in any known module. Following frames may be wrong.
0028f31c 6e5c4f85 0x2fe200b6
0028f354 6e5c57bf chrome_6d750000!v8::internal::Invoke+0x115 [d:\b\build\slave\chrome-official\build\src\v8\src\execution.cc @ 122]
0028f37c 6e594fb9 chrome_6d750000!v8::internal::Execution::Call+0x5f [d:\b\build\slave\chrome-official\build\src\v8\src\execution.cc @ 158]
0028f3b8 6d9387ac chrome_6d750000!v8::Function::Call+0x109 [d:\b\build\slave\chrome-official\build\src\v8\src\api.cc @ 3384]
0028f414 6d929d96 chrome_6d750000!WebCore::ScriptFunctionCall::call+0xc5 [d:\b\build\slave\chrome-official\build\src\third_party\webkit\source\webcore\bindings\v8\scriptfunctioncall.cpp @ 134]
0028f444 6d929e5f chrome_6d750000!WebCore::InjectedScript::makeCall+0x37 [d:\b\build\slave\chrome-official\build\src\third_party\webkit\source\webcore\inspector\injectedscript.cpp @ 203]
0028f478 6d9295fb chrome_6d750000!WebCore::InjectedScript::makeEvalCall+0x1c [d:\b\build\slave\chrome-official\build\src\third_party\webkit\source\webcore\inspector\injectedscript.cpp @ 228]
0028f4bc 6d8daa99 chrome_6d750000!WebCore::InjectedScript::evaluate+0x76 [d:\b\build\slave\chrome-official\build\src\third_party\webkit\source\webcore\inspector\injectedscript.cpp @ 64]
0028f504 6da7bf00 chrome_6d750000!WebCore::InspectorRuntimeAgent::evaluate+0x8a [d:\b\build\slave\chrome-official\build\src\third_party\webkit\source\webcore\inspector\inspectorruntimeagent.cpp @ 59]
0028f558 6da8f7b8 chrome_6d750000!WebCore::InspectorBackendDispatcher::Runtime_evaluate+0x1d5 [d:\b\build\slave\chrome-official\build\src\build\release\obj\global_intermediate\webcore\inspectorbackenddispatcher.cpp @ 505]
0028f5b8 6dafaac1 chrome_6d750000!WebCore::InspectorBackendDispatcher::dispatch+0x1e52 [d:\b\build\slave\chrome-official\build\src\build\release\obj\global_intermediate\webcore\inspectorbackenddispatcher.cpp @ 4301]
0028f5cc 6dd195db chrome_6d750000!WebKit::WebDevToolsAgentImpl::dispatchOnInspectorBackend+0x2b [d:\b\build\slave\chrome-official\build\src\third_party\webkit\source\webkit\chromium\src\webdevtoolsagentimpl.cpp @ 235]
0028f5e4 6ddc2ba9 chrome_6d750000!DevToolsAgent::OnDispatchOnInspectorBackend+0x26 [d:\b\build\slave\chrome-official\build\src\chrome\renderer\devtools_agent.cc @ 175]

Downstream bug: http://code.google.com/p/chromium/issues/detail?id=83401
Comment 1 Yury Semikhatsky 2011-05-23 02:47:08 PDT

*** This bug has been marked as a duplicate of bug 61194 ***