Bug 60704

Summary: 2011-05-12 David Kilzer <ddkilzer@apple.com>
Product: WebKit Reporter: David Kilzer (:ddkilzer) <ddkilzer>
Component: JavaScriptCoreAssignee: David Kilzer (:ddkilzer) <ddkilzer>
Status: RESOLVED DUPLICATE    
Severity: Normal    
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   

Description David Kilzer (:ddkilzer) 2011-05-12 10:28:00 PDT
<http://webkit.org/b/00000> JavaScriptGlue should compile with -Wmissing-prototypes

Reviewed by NOBODY (OOPS!).

Enabling -Wmissing-prototypes fixes an Xcode 4 project warning.

This also fixes the following compiler warning:

JavaScriptGlue/JSUtils.cpp:407:15: error: no previous prototype for function 'getThreadGlobalData' [-Werror,-Wmissing-prototypes,3]
JSGlobalData* getThreadGlobalData()
^

* Configurations/Base.xcconfig: Set
GCC_WARN_ABOUT_MISSING_PROTOTYPES = YES.
* JSUtils.cpp:
(getThreadGlobalData): Made static.
Comment 1 David Kilzer (:ddkilzer) 2011-05-12 12:05:59 PDT
*sigh* "webkit-patch upload" fail.  I was trying to make it smarter about reusing a local commit log.  It also likes to create bugs at the drop of a hat.

*** This bug has been marked as a duplicate of bug 60710 ***
Comment 2 Darin Adler 2014-04-24 16:45:21 PDT
Moving all JavaScriptGlue bugs to JavaScriptCore. The JavaScriptGlue framework itself is long gone. And most of the more recent bugs put in this component were put there by people who thought this was for some other aspect of “JavaScript glue” and have nothing to do with the actual original reason for the existence of this component, which was an OS-X-only framework named JavaScriptGlue.