Bug 60676

Summary: Enable OwnPtr strict mode in libxml2 XMLDocumentParser
Product: WebKit Reporter: Patrick R. Gansterer <paroga>
Component: New BugsAssignee: Patrick R. Gansterer <paroga>
Status: RESOLVED DUPLICATE    
Severity: Normal CC: abarth, dglazkov, webkit.review.bot
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Attachments:
Description Flags
Patch
none
Patch abarth: review-

Description Patrick R. Gansterer 2011-05-11 17:15:01 PDT
Enable OwnPtr strict mode in libxml2 XMLDocumentParser
Comment 1 Patrick R. Gansterer 2011-05-11 17:16:19 PDT
Created attachment 93217 [details]
Patch
Comment 2 WebKit Review Bot 2011-05-11 17:22:29 PDT
Comment on attachment 93217 [details]
Patch

Attachment 93217 [details] did not pass chromium-ews (chromium-xvfb):
Output: http://queues.webkit.org/results/8691388
Comment 3 Patrick R. Gansterer 2011-05-11 17:35:11 PDT
Created attachment 93222 [details]
Patch
Comment 4 Adam Barth 2011-05-11 17:39:02 PDT
Comment on attachment 93222 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=93222&action=review

> Source/WebCore/dom/XMLDocumentParserLibxml2.cpp:191
> -        OwnPtr<PendingCallback> callback(m_callbacks.takeFirst());
> +        OwnPtr<PendingCallback> callback = adoptPtr(m_callbacks.takeFirst());

This change is not correct.  m_callbacks should old OwnPtrs and takeFirst should return a PassOwnPtr.  I thought Maceij wrote a patch that did that?  Maybe he added the ability to Deque but didn't change the type in this file?
Comment 5 Adam Barth 2011-05-11 17:39:21 PDT
s/old/hold/
Comment 6 Patrick R. Gansterer 2011-05-11 18:35:12 PDT
(In reply to comment #4)
> This change is not correct.  m_callbacks should old OwnPtrs and takeFirst should return a PassOwnPtr.  I thought Maceij wrote a patch that did that?  Maybe he added the ability to Deque but didn't change the type in this file?

I don't see such code in Dequeue. Do you have an idea when he made this change?
Comment 7 Adam Barth 2011-05-11 18:50:48 PDT
Maybe he never landed it?  We should ask him on irc.
Comment 8 Patrick R. Gansterer 2011-05-12 14:40:13 PDT

*** This bug has been marked as a duplicate of bug 59394 ***