Bug 60649

Summary: [Qt] Extract code to set mouse event modifiers into common function
Product: WebKit Reporter: Daniel Bates <dbates>
Component: UI EventsAssignee: Daniel Bates <dbates>
Severity: Normal CC: benjamin, kling, ossy
Priority: P2 Keywords: Qt
Version: 528+ (Nightly build)   
Hardware: All   
OS: All   
Description Flags
Patch none

Description Daniel Bates 2011-05-11 13:00:28 PDT
Both PlatformMouseEvent(QInputEvent*, int clickCount) and PlatformMouseEvent(QGraphicsSceneMouseEvent*, int clickCount) contain identical code to set the state of the keyboard modifiers for a mouse event. Instead, we should extract this code into a common function, say mouseEventModifiersFromQtKeyboardModifiers() so as to remove duplicate code.
Comment 1 Daniel Bates 2011-05-11 13:11:07 PDT
Created attachment 93163 [details]
Comment 2 Daniel Bates 2011-05-11 14:35:54 PDT
Comment on attachment 93163 [details]

Clearing flags on attachment: 93163

Committed r86273: <http://trac.webkit.org/changeset/86273>
Comment 3 Daniel Bates 2011-05-11 14:36:00 PDT
All reviewed patches have been landed.  Closing bug.