Bug 60048

Summary: store results.html options in localstorage
Product: WebKit Reporter: Ojan Vafai <ojan>
Component: New BugsAssignee: Ojan Vafai <ojan>
Status: RESOLVED FIXED    
Severity: Normal CC: eric, mihaip, tony
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Other   
OS: OS X 10.5   
Attachments:
Description Flags
Patch tony: review+

Description Ojan Vafai 2011-05-03 11:49:56 PDT
store results.html options in localstorage
Comment 1 Ojan Vafai 2011-05-03 11:51:33 PDT
Created attachment 92098 [details]
Patch
Comment 2 Eric Seidel (no email) 2011-05-03 12:03:17 PDT
Comment on attachment 92098 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=92098&action=review

> LayoutTests/fast/harness/resources/results-test.js:65
> +function runTest(results, assertions, opt_localStorageValue)

opt_?  Funny prefix.
Comment 3 Ojan Vafai 2011-05-03 12:15:09 PDT
(In reply to comment #2)
> (From update of attachment 92098 [details])
> View in context: https://bugs.webkit.org/attachment.cgi?id=92098&action=review
> 
> > LayoutTests/fast/harness/resources/results-test.js:65
> > +function runTest(results, assertions, opt_localStorageValue)
> 
> opt_?  Funny prefix.

It's a convention I picked up from Google's JS code. I'm happy to remove the prefix or do something different. It's useful to be able to specify that an argument is optional though.
Comment 4 Tony Chang 2011-05-03 13:37:32 PDT
Comment on attachment 92098 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=92098&action=review

>>> LayoutTests/fast/harness/resources/results-test.js:65

>> 
>> opt_?  Funny prefix.
> 
> It's a convention I picked up from Google's JS code. I'm happy to remove the prefix or do something different. It's useful to be able to specify that an argument is optional though.

The opt_ prefix seems fine considering we already checked in some code for it.  We can discuss/change if we decide to have a JS style guide.
Comment 5 Ojan Vafai 2011-05-03 13:51:59 PDT
Committed r85654: <http://trac.webkit.org/changeset/85654>