Bug 59044

Summary: [Qt][WK2] Emit QWKPage::urlChanged() when navigating within the same document.
Product: WebKit Reporter: Andreas Kling <kling>
Component: WebKit QtAssignee: Andreas Kling <kling>
Status: RESOLVED FIXED    
Severity: Normal CC: webkit.review.bot
Priority: P2 Keywords: Qt, QtTriaged
Version: 528+ (Nightly build)   
Hardware: All   
OS: All   
Attachments:
Description Flags
Proposed patch kenneth: review+

Description Andreas Kling 2011-04-20 17:16:42 PDT
SSIA
Comment 1 Andreas Kling 2011-04-20 17:17:31 PDT
Created attachment 90453 [details]
Proposed patch
Comment 2 WebKit Review Bot 2011-04-20 17:20:15 PDT
Attachment 90453 [details] did not pass style-queue:

Failed to run "['Tools/Scripts/check-webkit-style', '--diff-files', u'Source/WebKit2/ChangeLog', u'Source/WebKit..." exit_code: 1

Source/WebKit2/UIProcess/API/qt/ClientImpl.h:46:  The parameter name "page" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/WebKit2/UIProcess/API/qt/ClientImpl.h:46:  The parameter name "frame" adds no information, so it should be removed.  [readability/parameter_name] [5]
Source/WebKit2/UIProcess/API/qt/ClientImpl.h:46:  The parameter name "type" adds no information, so it should be removed.  [readability/parameter_name] [5]
Total errors found: 3 in 4 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 3 Kenneth Rohde Christiansen 2011-04-21 03:57:07 PDT
Comment on attachment 90453 [details]
Proposed patch

View in context: https://bugs.webkit.org/attachment.cgi?id=90453&action=review

>>>> Source/WebKit2/UIProcess/API/qt/ClientImpl.h:46
>>>> +void qt_wk_didSameDocumentNavigationForFrame(WKPageRef page, WKFrameRef frame, WKSameDocumentNavigationType type, WKTypeRef userData, const void *clientInfo);
>>> 
>>> The parameter name "page" adds no information, so it should be removed.  [readability/parameter_name] [5]
>> 
>> The parameter name "frame" adds no information, so it should be removed.  [readability/parameter_name] [5]
> 
> The parameter name "type" adds no information, so it should be removed.  [readability/parameter_name] [5]

I agree with the style guide here :-) only clientInfo and userData brings value
Comment 4 Andreas Kling 2011-04-21 12:32:17 PDT
Committed r84539: <http://trac.webkit.org/changeset/84539>