Bug 58496

Summary: Add webkit prefix to Blob.slice method and change its semantics to be like Array.slice
Product: WebKit Reporter: Jian Li <jianli>
Component: WebCore JavaScriptAssignee: Jian Li <jianli>
Status: RESOLVED FIXED    
Severity: Normal CC: dimich, fishd
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: PC   
OS: All   
Attachments:
Description Flags
Proposed Patch
jianli: commit-queue-
Proposed Patch fishd: review+, jianli: commit-queue-

Description Jian Li 2011-04-13 17:08:30 PDT
Add webkit prefix to Blob.slice method and change its semantics to be like Array.slice, per the latest discussion on public-webapps.
Comment 1 Jian Li 2011-04-13 17:15:29 PDT
Created attachment 89496 [details]
Proposed Patch
Comment 2 Jian Li 2011-04-13 17:17:48 PDT
Created attachment 89498 [details]
Proposed Patch
Comment 3 Jian Li 2011-04-14 11:15:34 PDT
Committed as http://trac.webkit.org/changeset/83873.