Bug 58496 - Add webkit prefix to Blob.slice method and change its semantics to be like Array.slice
Summary: Add webkit prefix to Blob.slice method and change its semantics to be like Ar...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebCore JavaScript (show other bugs)
Version: 528+ (Nightly build)
Hardware: PC All
: P2 Normal
Assignee: Jian Li
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-04-13 17:08 PDT by Jian Li
Modified: 2011-04-14 11:15 PDT (History)
2 users (show)

See Also:


Attachments
Proposed Patch (16.10 KB, patch)
2011-04-13 17:15 PDT, Jian Li
jianli: commit-queue-
Details | Formatted Diff | Diff
Proposed Patch (16.09 KB, patch)
2011-04-13 17:17 PDT, Jian Li
fishd: review+
jianli: commit-queue-
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Jian Li 2011-04-13 17:08:30 PDT
Add webkit prefix to Blob.slice method and change its semantics to be like Array.slice, per the latest discussion on public-webapps.
Comment 1 Jian Li 2011-04-13 17:15:29 PDT
Created attachment 89496 [details]
Proposed Patch
Comment 2 Jian Li 2011-04-13 17:17:48 PDT
Created attachment 89498 [details]
Proposed Patch
Comment 3 Jian Li 2011-04-14 11:15:34 PDT
Committed as http://trac.webkit.org/changeset/83873.