Bug 58386

Summary: [chromium] Fix spellcheck regression in context menus
Product: WebKit Reporter: John Abd-El-Malek <jam>
Component: New BugsAssignee: John Abd-El-Malek <jam>
Status: RESOLVED FIXED    
Severity: Normal CC: jianli
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Other   
OS: OS X 10.5   
Attachments:
Description Flags
Patch jianli: review+

Description John Abd-El-Malek 2011-04-12 15:54:13 PDT
[chromium] Fix spellcheck regression in context menus
Comment 1 John Abd-El-Malek 2011-04-12 15:57:53 PDT
Created attachment 89292 [details]
Patch
Comment 2 John Abd-El-Malek 2011-04-12 15:58:45 PDT
My original change was incorrect, since the offset is 0 when the first word is the one that's misspelt.  The length will be non-zero if there's a misspelling though, per WebSpellCheckClient comments.
Comment 3 John Abd-El-Malek 2011-04-12 16:22:23 PDT
Committed r83660: <http://trac.webkit.org/changeset/83660>