Bug 58187

Summary: Web Inspector: refactor / document call frames in debugger domain.
Product: WebKit Reporter: Pavel Feldman <pfeldman>
Component: Web Inspector (Deprecated)Assignee: Nobody <webkit-unassigned>
Status: RESOLVED FIXED    
Severity: Normal CC: apavlov, bweinstein, joepeck, keishi, loislo, ossy, pfeldman, pmuellr, rik, timothy, webkit-ews, yurys
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: All   
OS: All   
Attachments:
Description Flags
Patch
none
Patch yurys: review+

Description Pavel Feldman 2011-04-09 01:09:18 PDT
Patch to follow. Note that it regresses visual representation a bit: we are not special casing with(element) and with(document) anymore and do not tell user that it is "Event target" and "Event document". However, strictly speaking, we should not have done it for with(element) not necessarily related to an event.
Comment 1 Pavel Feldman 2011-04-09 01:21:40 PDT
Created attachment 88925 [details]
Patch
Comment 2 Yury Semikhatsky 2011-04-10 23:40:40 PDT
Comment on attachment 88925 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=88925&action=review

> Source/WebCore/inspector/InjectedScriptSource.js:-513
> -                        scopeObjectProxy.isElement = true;

We should be able to figure it out on the front-end side and avoid the regression.

> Source/WebCore/inspector/front-end/ScopeChainSidebarPane.js:100
> +            if (scope.type !== "global") {

This way you won't expand global scope when it is the only one. This is a regression.
Comment 3 Pavel Feldman 2011-04-11 02:13:11 PDT
Created attachment 88977 [details]
Patch
Comment 4 Early Warning System Bot 2011-04-11 03:19:16 PDT
Attachment 88977 [details] did not build on qt:
Build output: http://queues.webkit.org/results/8376824
Comment 5 Csaba Osztrogon√°c 2011-04-11 03:52:55 PDT
(In reply to comment #4)
> Attachment 88977 [details] did not build on qt:
> Build output: http://queues.webkit.org/results/8376824

It was a false positive alarm, sorry for the inconvenience.

I fixed the Qt EWS, and tried to build this patch manually,
and it works for me. ;)
Comment 6 Pavel Feldman 2011-04-11 04:45:26 PDT
Committed r83434: <http://trac.webkit.org/changeset/83434>