Bug 57869

Summary: REGRESSION (r82734): Links in Leaks Viewer's Recent Builds list don't work
Product: WebKit Reporter: Adam Roben (:aroben) <aroben>
Component: Tools / TestsAssignee: Nobody <webkit-unassigned>
Status: RESOLVED FIXED    
Severity: Normal    
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: All   
OS: All   
URL: http://build.webkit.org/LeaksViewer/
Attachments:
Description Flags
Strip off /results.html from results URLs before trying to load leaks files from them joepeck: review+

Description Adam Roben (:aroben) 2011-04-05 11:50:07 PDT
To reproduce:

1. Go to <http://build.webkit.org/LeaksViewer/>
2. Click on a recent build

The leaks from that build never load.
Comment 1 Adam Roben (:aroben) 2011-04-05 11:50:29 PDT
r82734 changed the "view results" links to point to results.html. Leaks Viewer expects them to point to the directory that contains results.html. Should be easy to fix.
Comment 2 Adam Roben (:aroben) 2011-04-05 11:59:45 PDT
Created attachment 88290 [details]
Strip off /results.html from results URLs before trying to load leaks files from them
Comment 3 Joseph Pecoraro 2011-04-05 12:33:48 PDT
Comment on attachment 88290 [details]
Strip off /results.html from results URLs before trying to load leaks files from them

View in context: https://bugs.webkit.org/attachment.cgi?id=88290&action=review

> Tools/BuildSlaveSupport/build.webkit.org-config/public_html/LeaksViewer/RecentBuildsLoader.js:65
> +                        var url = step.urls["view results"];
> +                        buildInfo.url = self._buildbotBaseURL + url.replace(/\/results\.html$/, "") + "/";

If all the build bots point to ".../results.html" you only need to chop off the results.html part and not add the slash. But I think the current approach works well because it always ensures a slash at the end.
Comment 4 Adam Roben (:aroben) 2011-04-05 12:35:47 PDT
Comment on attachment 88290 [details]
Strip off /results.html from results URLs before trying to load leaks files from them

View in context: https://bugs.webkit.org/attachment.cgi?id=88290&action=review

>> Tools/BuildSlaveSupport/build.webkit.org-config/public_html/LeaksViewer/RecentBuildsLoader.js:65
>> +                        buildInfo.url = self._buildbotBaseURL + url.replace(/\/results\.html$/, "") + "/";
> 
> If all the build bots point to ".../results.html" you only need to chop off the results.html part and not add the slash. But I think the current approach works well because it always ensures a slash at the end.

That was exactly my thinking. (Old builds don't include the "/results.html", but of course that isn't a concern for RecentBuildsLoader.)
Comment 5 Adam Roben (:aroben) 2011-04-05 13:00:26 PDT
Committed r82967: <http://trac.webkit.org/changeset/82967>