Bug 54482

Summary: Moved MarkedBlock data members to the head of the block
Product: WebKit Reporter: Geoffrey Garen <ggaren>
Component: New BugsAssignee: Geoffrey Garen <ggaren>
Status: RESOLVED FIXED    
Severity: Normal CC: webkit.review.bot
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Other   
OS: OS X 10.5   
Attachments:
Description Flags
Patch darin: review+

Description Geoffrey Garen 2011-02-15 11:54:27 PST
Moved MarkedBlock data members to the head of the block
Comment 1 Geoffrey Garen 2011-02-15 12:07:58 PST
Created attachment 82498 [details]
Patch
Comment 2 WebKit Review Bot 2011-02-15 12:11:16 PST
Attachment 82498 [details] did not pass style-queue:

Failed to run "['Tools/Scripts/check-webkit-style', '--diff-files', u'Source/JavaScriptCore/ChangeLog', u'Source..." exit_code: 1

Source/JavaScriptCore/runtime/MarkedBlock.h:53:  BLOCK_MASK is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
Source/JavaScriptCore/runtime/MarkedBlock.h:64:  CELLS_PER_BLOCK is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
Total errors found: 2 in 5 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 3 Darin Adler 2011-02-15 12:16:39 PST
Comment on attachment 82498 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=82498&action=review

Change seems fine. Could you please take a little time out and make the constants use normal style instead of MACRO_STYLE? Then the style bot would like you better.

> Source/JavaScriptCore/runtime/MarkedBlock.h:38
> +    template <size_t divisor> inline size_t roundUpToMultipleOf(size_t x)

Normally we don’t put a space between template and the "<" by analogy with the function name and "(".
Comment 4 Geoffrey Garen 2011-02-15 12:58:33 PST
> Could you please take a little time out and make the constants use normal style instead of MACRO_STYLE? Then the style bot would like you better.

OK, I'll do that in my next patch.
Comment 5 Geoffrey Garen 2011-02-15 13:03:21 PST
Committed r78605: <http://trac.webkit.org/changeset/78605>