Bug 53608

Summary: Enable media tests in chromium-gpu/test_expectations
Product: WebKit Reporter: Victoria Kirst <vrk>
Component: Tools / TestsAssignee: Victoria Kirst <vrk>
Status: RESOLVED FIXED    
Severity: Normal CC: commit-queue, dpranke, kbr, mihaip, vangelis, vrk
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: PC   
OS: OS X 10.5   
Bug Depends on: 55269    
Bug Blocks:    
Attachments:
Description Flags
Patch
none
Patch eric.carlson: review+, commit-queue: commit-queue-

Description Victoria Kirst 2011-02-02 11:22:54 PST
The media tests also trigger the GPU-accelerated compositing path, so media tests should be enabled.
Comment 1 Victoria Kirst 2011-02-02 11:50:43 PST
Created attachment 80939 [details]
Patch
Comment 2 Dirk Pranke 2011-02-02 12:08:20 PST
Looks fine to me, but I'm not a reviewer ...
Comment 3 Mihai Parparita 2011-02-02 14:23:25 PST
Comment on attachment 80939 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=80939&action=review

> LayoutTests/platform/chromium-gpu/test_expectations.txt:294
> +BUGWK53609 SKIP : media/controls-after-reload.html = IMAGE

These shouldn't be skipped, we'd still like to run them so that if they fail for another reason (e.g. text diff instead of image diff, or timeout) we'll know.
Comment 4 Dirk Pranke 2011-02-18 19:40:32 PST
This still needs to happen. Taking ownership.
Comment 5 Victoria Kirst 2011-02-24 18:11:08 PST
OK, figured out how to get DRT+Mesa working with media layout tests! It is the same problem as issue 54694. It has also unveiled other media bugs in rendering... The bugs are minor, so I'm not sure if I should wait to enable media/ until after the media bugs are fixed (for accurate expected results) or enable the tests then rebaseline? In any case..

dpranke: Can you assign this to me?
Comment 6 Dirk Pranke 2011-02-24 18:30:37 PST
sure, happy to. Feel free to steal bugs from me, too :)
Comment 7 Victoria Kirst 2011-03-01 18:19:18 PST
*** Bug 55540 has been marked as a duplicate of this bug. ***
Comment 8 Victoria Kirst 2011-03-01 18:25:51 PST
Created attachment 84346 [details]
Patch
Comment 9 WebKit Commit Bot 2011-03-03 01:26:53 PST
Comment on attachment 84346 [details]
Patch

Rejecting attachment 84346 [details] from commit-queue.

Failed to run "['./Tools/Scripts/webkit-patch', '--status-host=queues.webkit.org', '--bot-id=cr-jail-3', 'apply-..." exit_code: 2

Last 500 characters of output:

Hunk #1 succeeded at 1 with fuzz 3.
patching file LayoutTests/platform/chromium/test_expectations.txt
Hunk #1 FAILED at 3008.
1 out of 1 hunk FAILED -- saving rejects to file LayoutTests/platform/chromium/test_expectations.txt.rej
patching file Tools/ChangeLog
Hunk #1 succeeded at 1 with fuzz 3.
patching file Tools/Scripts/webkitpy/layout_tests/port/chromium_gpu.py

Failed to run "[u'/mnt/git/webkit-commit-queue/Tools/Scripts/svn-apply', u'--reviewer', u'Eric Carlson', u'--for..." exit_code: 1

Full output: http://queues.webkit.org/results/8083261
Comment 10 Mihai Parparita 2011-03-03 10:38:04 PST
I'll land this, since test_expectations.txt changes often enough that it can be hard to patch it via the commit queue.
Comment 11 Mihai Parparita 2011-03-03 10:39:36 PST
Committed r80257: <http://trac.webkit.org/changeset/80257>