Bug 50743

Summary: [GTK] Fix build with current gtk+
Product: WebKit Reporter: Carlos Garcia Campos <cgarcia>
Component: WebKitGTKAssignee: Nobody <webkit-unassigned>
Status: RESOLVED FIXED    
Severity: Normal CC: flo.gravo, gns, webkit.review.bot
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: PC   
OS: Linux   
Attachments:
Description Flags
Patch to fix the build with gtk3 none

Description Carlos Garcia Campos 2010-12-09 02:54:33 PST
gdk_window_get_geometry() api has changed.
Comment 1 Carlos Garcia Campos 2010-12-09 02:57:31 PST
Created attachment 76032 [details]
Patch to fix the build with gtk3
Comment 2 WebKit Review Bot 2010-12-09 02:59:34 PST
Attachment 76032 [details] did not pass style-queue:

Failed to run "['WebKitTools/Scripts/check-webkit-style', '--diff-files', u'WebCore/ChangeLog', u'WebCore/plugins/gtk/gtk2xtbin.c']" exit_code: 1
WebCore/plugins/gtk/gtk2xtbin.c:277:  Weird number of spaces at line-start.  Are you using a 4-space indent?  [whitespace/indent] [3]
WebCore/plugins/gtk/gtk2xtbin.c:277:  Extra space between gint and x  [whitespace/declaration] [3]
WebCore/plugins/gtk/gtk2xtbin.c:289:  Weird number of spaces at line-start.  Are you using a 4-space indent?  [whitespace/indent] [3]
WebCore/plugins/gtk/gtk2xtbin.c:291:  Weird number of spaces at line-start.  Are you using a 4-space indent?  [whitespace/indent] [3]
Total errors found: 4 in 2 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 3 Gustavo Noronha (kov) 2010-12-09 03:12:19 PST
Comment on attachment 76032 [details]
Patch to fix the build with gtk3

we are landing a different patch already
Comment 4 Gustavo Noronha (kov) 2010-12-09 03:35:22 PST
*** Bug 50563 has been marked as a duplicate of this bug. ***
Comment 5 Gustavo Noronha (kov) 2010-12-09 03:36:30 PST
This was fixed in r73603.