Bug 50563

Summary: [PATCH] Adapt WebKit to API change in gdk_window_get_geometry
Product: WebKit Reporter: Florian Gawrilowicz <flo.gravo>
Component: PlatformAssignee: Nobody <webkit-unassigned>
Status: RESOLVED DUPLICATE    
Severity: Normal CC: gns
Priority: P2    
Version: 420+   
Hardware: PC   
OS: Linux   
Attachments:
Description Flags
Possible patch
none
Using GTK_CHECK_VERSION none

Description Florian Gawrilowicz 2010-12-06 05:20:21 PST
Created attachment 75678 [details]
Possible patch

"gdk_window_get_geometry" dropped the "gint *depth" argument in GTK-2.91.6,
which wasn't used anyway. It caused the following error:

make[1]: Entering directory `/home//co/gnome3/webkit-1.3.7'
  CC     WebCore/plugins/gtk/libwebkitgtk_3_0_la-gtk2xtbin.lo
  CXX    WebCore/platform/graphics/freetype/libwebkitgtk_3_0_la-FontPlatformDataFreeType.lo
  CXX    WebKit/gtk/WebCoreSupport/libwebkitgtk_3_0_la-ChromeClientGtk.lo
WebCore/plugins/gtk/gtk2xtbin.c: In function 'gtk_xtbin_realize':
WebCore/plugins/gtk/gtk2xtbin.c:288:3: error: too many arguments to function 'gdk_window_get_geometry'
/opt/gnome3/include/gtk-3.0/gdk/gdkwindow.h:719:12: note: declared here
make[1]: *** [WebCore/plugins/gtk/libwebkitgtk_3_0_la-gtk2xtbin.lo] Error 1
make[1]: *** Waiting for unfinished jobs....
make[1]: Leaving directory `/home//co/gnome3/webkit-1.3.7'
Comment 1 Florian Gawrilowicz 2010-12-06 05:55:31 PST
Created attachment 75685 [details]
Using GTK_CHECK_VERSION
Comment 2 Gustavo Noronha (kov) 2010-12-09 03:35:22 PST

*** This bug has been marked as a duplicate of bug 50743 ***