Bug 49493

Summary: Web Inspector: [refactoring] support Views in TabbedPane and streamline tab selection in resource view
Product: WebKit Reporter: Andrey Kosyakov <caseq>
Component: Web Inspector (Deprecated)Assignee: Andrey Kosyakov <caseq>
Status: RESOLVED FIXED    
Severity: Normal CC: apavlov, bweinstein, joepeck, keishi, loislo, pfeldman, pmuellr, rik, timothy, yurys
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: All   
OS: All   
Attachments:
Description Flags
patch
pfeldman: review+, pfeldman: commit-queue-
patch to land none

Description Andrey Kosyakov 2010-11-13 07:04:11 PST
TabbedPane currently expects child "windows" to be tabs. The proposed patch adds support for Views that are selected via View.visible. This allows moving custom logic associated with tab being selected into overridden View.Show(), which, in turn, allows to streamline tab selection logic in ResourceView.
Comment 1 Andrey Kosyakov 2010-11-13 07:14:08 PST
Created attachment 73823 [details]
patch
Comment 2 Andrey Kosyakov 2010-11-13 07:19:13 PST
(In reply to comment #0)
> TabbedPane currently expects child "windows" to be tabs. 
s/tabs/elements/
Comment 3 Pavel Feldman 2010-11-13 07:47:24 PST
Comment on attachment 73823 [details]
patch

View in context: https://bugs.webkit.org/attachment.cgi?id=73823&action=review

> WebCore/ChangeLog:10
> +        No new tests. (OOPS!)

Remove this line.

> WebCore/inspector/front-end/ResourceView.js:163
> +                tab = this.tabbedPane.hasTab(preferredTab) ? preferredTab : "headers";

We used to go to "content" by default, now we should "headers". However, now that we have split resources and network, I think this is right!

> WebCore/inspector/front-end/TabbedPane.js:72
> +    _setSelection: function(tabObject, isSelected)

split this into _showTab and _hideTab?
Comment 4 Andrey Kosyakov 2010-11-13 08:20:19 PST
Created attachment 73827 [details]
patch to land

All review comments addressed.
Comment 5 Andrey Kosyakov 2010-11-13 08:42:04 PST
Manually committed r71967: http://trac.webkit.org/changeset/71967