Bug 48907

Summary: Make it possible to delegate scrolling to the UI
Product: WebKit Reporter: Kenneth Rohde Christiansen <kenneth>
Component: WebCore Misc.Assignee: Nobody <webkit-unassigned>
Status: RESOLVED FIXED    
Severity: Normal CC: hyatt, kling
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: PC   
OS: All   
Attachments:
Description Flags
Patch kling: review+

Kenneth Rohde Christiansen
Reported 2010-11-03 05:40:44 PDT
This is needed for client using a tiled scrolling implementation and thus delegating scrolling to the ui. In WebKit2 this is even more important as this cannot be implemented using the platformWidget().
Attachments
Patch (7.69 KB, patch)
2010-11-03 05:51 PDT, Kenneth Rohde Christiansen
kling: review+
Kenneth Rohde Christiansen
Comment 1 2010-11-03 05:51:24 PDT
Created attachment 72815 [details] Patch This is basically a clean up version of the patch that I showed Hyatt on irc yesterday: <kenneth> dhyatt, proof of concept, feel free to comment: http://qt.pastebin.com/GHtt6xqM <dhyatt> kenneth: yeah that looks pretty good
Andreas Kling
Comment 2 2010-11-03 06:25:27 PDT
Comment on attachment 72815 [details] Patch View in context: https://bugs.webkit.org/attachment.cgi?id=72815&action=review r=me > WebCore/page/FrameView.h:79 > + virtual bool delegateScrolling(); I think we should call it shouldDelegateScrolling() here as well.
Kenneth Rohde Christiansen
Comment 3 2010-11-03 07:27:06 PDT
(In reply to comment #2) > (From update of attachment 72815 [details]) > View in context: https://bugs.webkit.org/attachment.cgi?id=72815&action=review > > r=me > > > WebCore/page/FrameView.h:79 > > + virtual bool delegateScrolling(); > > I think we should call it shouldDelegateScrolling() here as well. Everythign in FrameView and ScrollView is that way, like paintsEntireContents, avoidScrollbarCreation, etc.
Andreas Kling
Comment 4 2010-11-03 07:29:51 PDT
(In reply to comment #3) > (In reply to comment #2) > > (From update of attachment 72815 [details] [details]) > > View in context: https://bugs.webkit.org/attachment.cgi?id=72815&action=review > > > > r=me > > > > > WebCore/page/FrameView.h:79 > > > + virtual bool delegateScrolling(); > > > > I think we should call it shouldDelegateScrolling() here as well. > > Everythign in FrameView and ScrollView is that way, like paintsEntireContents, avoidScrollbarCreation, etc. delegatesScrolling() then? *bikesheds* I just don't like the imperative sound of "delegate scrolling."
Andreas Kling
Comment 5 2010-11-03 08:01:05 PDT
Note You need to log in before you can comment on or make changes to this bug.