Bug 48778

Summary: Start stubbing out NPClass functions in NPObjectProxy
Product: WebKit Reporter: Anders Carlsson <andersca>
Component: New BugsAssignee: Anders Carlsson <andersca>
Status: RESOLVED FIXED    
Severity: Normal CC: webkit.review.bot
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Other   
OS: OS X 10.5   
Attachments:
Description Flags
Patch aroben: review+

Description Anders Carlsson 2010-11-01 14:00:24 PDT
Start stubbing out NPClass functions in NPObjectProxy
Comment 1 Anders Carlsson 2010-11-01 14:04:31 PDT
Created attachment 72554 [details]
Patch
Comment 2 WebKit Review Bot 2010-11-01 14:07:53 PDT
Attachment 72554 [details] did not pass style-queue:

Failed to run "['WebKitTools/Scripts/check-webkit-style']" exit_code: 1
WebKit2/Shared/Plugins/NPObjectProxy.cpp:84:  NPObjectProxy::NP_Allocate is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
WebKit2/Shared/Plugins/NPObjectProxy.cpp:91:  NPObjectProxy::NP_Deallocate is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
WebKit2/Shared/Plugins/NPObjectProxy.cpp:97:  NPObjectProxy::NP_HasMethod is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
WebKit2/Shared/Plugins/NPObjectProxy.cpp:103:  NPObjectProxy::NP_Invoke is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
WebKit2/Shared/Plugins/NPObjectProxy.cpp:109:  NPObjectProxy::NP_InvokeDefault is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
WebKit2/Shared/Plugins/NPObjectProxy.cpp:115:  NPObjectProxy::NP_HasProperty is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
WebKit2/Shared/Plugins/NPObjectProxy.cpp:121:  NPObjectProxy::NP_GetProperty is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
WebKit2/Shared/Plugins/NPObjectProxy.cpp:127:  NPObjectProxy::NP_SetProperty is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
WebKit2/Shared/Plugins/NPObjectProxy.cpp:133:  NPObjectProxy::NP_RemoveProperty is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
WebKit2/Shared/Plugins/NPObjectProxy.cpp:139:  NPObjectProxy::NP_Enumerate is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
WebKit2/Shared/Plugins/NPObjectProxy.cpp:145:  NPObjectProxy::NP_Construct is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
Total errors found: 11 in 7 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 3 Anders Carlsson 2010-11-01 14:12:53 PDT
Committed r71054: <http://trac.webkit.org/changeset/71054>