Bug 46549

Summary: Crash in -[NSFileManager(WebNSFileManagerExtras) _webkit_setMetadataURL:referrer:atPath:] when opening download link
Product: WebKit Reporter: Dimitris Apostolou <dimitris.apostolou>
Component: New BugsAssignee: Nobody <webkit-unassigned>
Status: CLOSED DUPLICATE    
Severity: Major    
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Macintosh Intel   
OS: OS X 10.6   
URL: http://c-command.com/downloads/SpamSieve-2.8.4b2.dmg
Attachments:
Description Flags
Crash log. none

Description Dimitris Apostolou 2010-09-24 20:20:01 PDT
Created attachment 68806 [details]
Crash log.

5.0.2 (6533.18.5, r68242)

Steps:
Paste http://c-command.com/downloads/SpamSieve-2.8.4b2.dmg to address text field and press enter.

What happened:
Crash.

Thread 0 Crashed:  Dispatch queue: com.apple.main-thread
0   com.apple.CoreFoundation      	0x00007fff824a1890 CFStringCreateCopy + 48
1   com.apple.WebKit              	0x0000000100a5fb01 -[NSFileManager(WebNSFileManagerExtras) _webkit_setMetadataURL:referrer:atPath:] + 177
2   com.apple.Safari              	0x00000001000fd613 0x100000000 + 1037843
3   com.apple.Safari              	0x00000001000fd3e2 0x100000000 + 1037282
4   com.apple.Safari              	0x00000001000fd0a9 0x100000000 + 1036457
5   com.apple.Foundation          	0x00007fff829f5a2a _NSURLDownloadDecideDestinationWithSuggestedObjectName + 123
6   com.apple.CFNetwork           	0x00007fff87ac5115 URLDownload::downloadOpenTarget() + 213
7   com.apple.CFNetwork           	0x00007fff87ac54d2 URLDownload::downloadWriteData(long, __CFData const*, __CFData const*, __CFError**, unsigned char) + 68
8   com.apple.CFNetwork           	0x00007fff87ac5dda URLDownload::downloadProcessData(__CFData const*, unsigned char) + 480
9   com.apple.CFNetwork           	0x00007fff87ac5ecc URLDownload::didReceiveData(__CFData const*, long) + 46
10  com.apple.CFNetwork           	0x00007fff87a800c0 URLConnectionClient::_clientDidReceiveData(__CFData const*, URLConnectionClient::ClientConnectionEventQueue*) + 236
11  com.apple.CFNetwork           	0x00007fff87ae79a2 URLConnectionClient::ClientConnectionEventQueue::processAllEventsAndConsumePayload(XConnectionEventInfo<XClientEvent, XClientEventParams>*, long) + 218
12  com.apple.CFNetwork           	0x00007fff87a6e96d URLConnectionClient::processEvents() + 121
13  com.apple.CFNetwork           	0x00007fff87a6e748 MultiplexerSource::perform() + 160
14  com.apple.CoreFoundation      	0x00007fff824e74a1 __CFRunLoopDoSources0 + 1361
15  com.apple.CoreFoundation      	0x00007fff824e5699 __CFRunLoopRun + 873
16  com.apple.CoreFoundation      	0x00007fff824e4e5f CFRunLoopRunSpecific + 575
17  com.apple.HIToolbox           	0x00007fff8648691a RunCurrentEventLoopInMode + 333
18  com.apple.HIToolbox           	0x00007fff8648671f ReceiveNextEventCommon + 310
19  com.apple.HIToolbox           	0x00007fff864865d8 BlockUntilNextEventMatchingListInMode + 59
20  com.apple.AppKit              	0x00007fff841fde64 _DPSNextEvent + 718
21  com.apple.AppKit              	0x00007fff841fd7a9 -[NSApplication nextEventMatchingMask:untilDate:inMode:dequeue:] + 155
22  com.apple.Safari              	0x00000001000165d4 0x100000000 + 91604
23  com.apple.AppKit              	0x00007fff841c348b -[NSApplication run] + 395
24  com.apple.AppKit              	0x00007fff841bc1a8 NSApplicationMain + 364
25  com.apple.Safari              	0x000000010000a4a0 0x100000000 + 42144

Expected result:
WebKit does not crash.
Comment 1 Alexey Proskuryakov 2010-09-25 16:16:27 PDT

*** This bug has been marked as a duplicate of bug 46380 ***
Comment 2 Dimitris Apostolou 2010-09-27 22:47:59 PDT
Verified with r68419.

Closing.