Bug 46032

Summary: check-webkit-style complains about unincluded config.h in WebKit2 code
Product: WebKit Reporter: Andras Becsi <abecsi>
Component: Tools / TestsAssignee: Nobody <webkit-unassigned>
Status: RESOLVED DUPLICATE    
Severity: Normal CC: cjerdonek, levin, ossy, sam
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: PC   
OS: All   

Description Andras Becsi 2010-09-18 05:35:21 PDT
In WebKit2 code including config.h is not needed but check-webkit-style complains about it's absence:

Found header this file implements before WebCore config.h. Should be: config.h, primary header, blank line, and then alphabetically sorted.  [build/include_order] [4]
Comment 1 Csaba Osztrogon√°c 2010-09-21 03:57:34 PDT
Additionally we should mention in "WebKit Coding Style Guidelines"
that including config.h is unnecessary.
Comment 2 David Levin 2010-11-02 14:01:47 PDT
Sounds like this was fixed in 48638.

*** This bug has been marked as a duplicate of bug 48638 ***